PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Conditional Logic not working with Radio Buttons

  1. Hello all,

    I'm having an issue with radio buttons displaying if I add any sort of conditional logic.

    Here is my setup

    Field: Collection
    Field Type: Radio Button
    Label1 = Round Door1 + HTML for image
    Value1 = Round Doors
    Price1 = 100

    Label2 = Round Door2 + HTML for image
    Value2 = Round Doors
    Price2 = 100

    Label3 = Round Door3 + HTML for image
    Value3 = Round Doors
    Price3 = 100

    What I need to happen is when an option is selected the images disappear and the next set of options appear. But, I can't even get the first set of options to appear unless I turn off conditional logic.

    Any help is appreciated.

    Shawn

    Posted 8 years ago on Saturday March 3, 2012 | Permalink
  2. Shawn, have you tested the form via the formbuilder's preview mode to see if it works when you turn your conditional logic on? If you do and the form works there, then you should test for theme/plugin conflicts:

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 8 years ago on Saturday March 3, 2012 | Permalink
  3. Rob,

    It doesn't show in the preview form with conditional logic enabled. I haven't even tried it on my site yet.

    Shawn

    Posted 8 years ago on Saturday March 3, 2012 | Permalink
  4. Update

    I created another Product form as a radio button with two options if I use conditional logic on that one as well it disable both Product forms from showing. Even if the other doesn't have conditioanl logic enabled...weird???

    Shawn

    Posted 8 years ago on Saturday March 3, 2012 | Permalink
  5. Update #2

    If I use conditional logic in the form in anyway nothing works not even in a simple html field.

    Shawn

    Posted 8 years ago on Saturday March 3, 2012 | Permalink
  6. Update #3

    I crated a brand new for and still have the same issues with radio buttons showing if I add enable conditional logic.

    Ideas?

    Shawn

    Posted 8 years ago on Saturday March 3, 2012 | Permalink
  7. Shawn can you shoot me a login to rob@rocketgenius.com

    Posted 8 years ago on Saturday March 3, 2012 | Permalink
  8. I am having the same issue. Have you figured out anything?

    Posted 8 years ago on Friday March 9, 2012 | Permalink
  9. @GarySargent can you send me a login to rob@rocketgenius.com so I can take a look around?

    Posted 8 years ago on Sunday March 11, 2012 | Permalink
  10. We got it figured out, thank you.

    Posted 7 years ago on Monday May 14, 2012 | Permalink

This topic has been resolved and has been closed to new replies.