PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Conditional Logic stops form showing

  1. I have a form that shows up without a problem, but as soon as I add conditional logic, the form no longer shows up.

    I've tried with both a section break and page break, as well as individual fields, and it is at the point of adding conditional logic that it stops showing.

    I'm using the latest versions of both WordPress & Gravity Forms.

    Posted 6 years ago on Sunday June 2, 2013 | Permalink
  2. Richard Vav
    Administrator

    Hi Joe,

    When a form that uses conditional logic fails to be displayed it is because a javascript error is preventing the Gravity Forms scripts from running. The most common cause is jQuery being loaded twice either by a badly coded theme or plugin, if you can provide a link to the page containing the form that isn't appearing then we can take a look and possibly spot the problem.

    If the problem isn't being caused by multiple jQuery files then you are going to have to work through the theme/plugin troubleshooting steps to narrow down and locate the cause.

    Regards,
    Richard

    Posted 6 years ago on Sunday June 2, 2013 | Permalink
  3. Hi Richard,

    It looks like it could be a theme conflict, but that's strange as I always use this theme and haven't had a problem with it in the past.

    It's the Canvas theme from WooThemes, so a strange problem.

    Posted 6 years ago on Sunday June 2, 2013 | Permalink
  4. Even stranger, is that when I just put Canvas back on,it works :/

    EDIT
    It seems that having ajax set to 'true' caused the problem

    Posted 6 years ago on Sunday June 2, 2013 | Permalink
  5. Richard Vav
    Administrator

    Thanks for the update, glad you figured it out. You may want to report the problem to WooThemes so they can look into fixing the theme.

    Posted 6 years ago on Sunday June 2, 2013 | Permalink

This topic has been resolved and has been closed to new replies.