PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Confirmation page refuses to redirect

  1. I'm having trouble with my client's site: http://dawnwesterberg.com

    In the left sidebar there is a simple form with 3 fields. I've set it to redirect to another page upon submission, but it refuses to submit. And there are no entries showing up. Any idea what might be causing this form to fail?

    I'm using the Headway theme with several plugins including:
    - advertising manager
    - askimet
    - backupbuddy
    - google xml sitemaps
    - Gravity Forms PayPal Add-On
    - Headway HTML Sitemap
    - hotfix
    - sharethis
    - Styles with Shortcodes for WordPress
    - Twitter Tools
    - Wordpress Importer

    Posted 11 years ago on Wednesday August 3, 2011 | Permalink
  2. Was the form working at some point and stopped? Also, have you tried testing for plugin conflicts already? I know several of these do play nice with Gravity Forms, but am not familiar with all of them so can't say for sure. Give this a try and let us know what you find out.

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 11 years ago on Wednesday August 3, 2011 | Permalink
  3. Does that form need to have an AJAX submission? Just curious. I just saw the spinner then the page refreshed and moved the viewport some.

    I suspect it's a script conflict. When I disabled JavaScript in my browser, I was able to submit (you should have one entry of my 3 or 4 submissions - most were attempted before I disabled JavaScript.) After submission I ended up at this page:
    http://dawnwesterberg.com/download-free-e-books/

    You will have to test for plugin and theme conflicts by following the instructions here:
    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    More simply though, I think if you turn off the AJAX for the form that it will work without further changes to the site. With such a simple form with no need for JavaScript for conditional logic or a date picker, I think turning off the AJAX option in the widget settings will enable this to work. If that's the case, you can always try to find the source of the script conflict later.

    In the advanced settings for the widget, uncheck the box that says "Enable AJAX". I think everything will work after that.

    Posted 11 years ago on Wednesday August 3, 2011 | Permalink
  4. Thanks for your help. I followed those directions, but no luck. I disabled all plugins, and I also tried changing to the default theme, and also disabling Ajax, but nothing worked. It still wouldn't redirect the page upon submission. So I guess that means it must be some kind of script conflict, right?

    As for scripts, I'm using a footer script for Google Analytics and StatCounter. I tried removing those, but still it won't work.

    How can I find out what script is interfering with the submission form? Any idea?

    Posted 11 years ago on Wednesday August 3, 2011 | Permalink
  5. @astewart The problem is the form isn't submitting at all. Your web server is rejecting the POST action and returning a 403 Forbidden server error. See this screenshot: http://i.imgur.com/Ragkb.png

    You are going to need to discuss this with your web host. Explain to them the form is trying to POST and the web server is returning a 403 Forbidden error. Show them the screenshot I provided above which shows this error happening when the form submits.

    Posted 11 years ago on Wednesday August 3, 2011 | Permalink
  6. Thanks for hunting this down, Carl. I have written to anhosting's tech support to see if they can help resolve it. I'll post what I find out.

    Posted 11 years ago on Wednesday August 3, 2011 | Permalink
  7. AStewart - any resolution? I am about to give me host a call and am wondering if they fixed your issue & if so, how they did so.

    Posted 10 years ago on Tuesday October 18, 2011 | Permalink