PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Confirmation redirect not working

  1. Hi, I have one bug I cannot figure out at (contact us link in the footer).

    When the form is completed it is set to redirect to ( However it redirects and then is forced to another page. I'm not sure why. I have tried all three confirmation options (Text, Page, Redirect) and they all result in the same issue.

    Thanks for the help.

    Posted 11 years ago on Wednesday April 7, 2010 | Permalink
  2. looks like it's trying to pass some strange characters in the URL. It doesn't know how to reconcile that to a page/post and that's causing WordPress to redirect to your 404 page.

    URL Screenshot

    I would suggest going back and making sure your redirect URL is correctly formatted or that there aren't extra blank characters at the end.

    Posted 11 years ago on Wednesday April 7, 2010 | Permalink
  3. The first thing to do is check for a theme or plugin conflict by deactivating all other plugins and activating the default Kubrick theme and then test the form. If it works, re-activate your normal theme. If it still works then it's most likely a plugin conflict and you will need to activate them one by one and test Gravity Forms after each one to determine which one is causing the problem.

    If that isn't the issue you have something going on with your permalinks. Try editing your permalinks and resaving them. It could also be some sort of setting you have in your .htaccess file.

    Posted 11 years ago on Wednesday April 7, 2010 | Permalink
  4. Thanks for the help. I found the issue.

    I had not wrapped the widgets with the

    if ( function_exists('register_sidebar') ) {

    Once I went back to the Kubrick theme and everything was working, I saw I had commented out the above if statement.

    Posted 11 years ago on Thursday April 8, 2010 | Permalink