PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Conflict with Shopp Plugin - Cannot redeclare class AuthorizeNetARB

  1. I'm trying to setup a GravityForm to accept payments via Authorize.net. It's apparently conflicting with Shopp, which is also using Authorize.net. When I install the GF add-on my site errors out with

    Fatal Error: Cannot redeclare class AuthorizeNetARB in /wp-content/plugins/shopp/gateways/AuthorizeNet/Authorize.net.php on line 393

    Someone else had the same problem at this link but I'm not much of a coder and would like to find a way to correct this in GF rather than dicker around in Shopp.

    Any help certainly appreciated!

    -Anthony

    Posted 7 years ago on Friday November 2, 2012 | Permalink
  2. I've asked the developers for the best way forward here. Sorry about the inconvenience. We should hear back early in the week. Because you are a developer license holder, you can also take advantage of the Priority Support. If you do, please be sure to reference this topic in your request. Thank you.

    Posted 7 years ago on Sunday November 4, 2012 | Permalink