PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

contact page just refreshing

  1. When I run a test I get the email but when someone actually tries to contact me via my form on http://scottwyden.com/contact it doesn't go through. I am told the page just refreshes. Nothing has changed.

    Posted 11 years ago on Tuesday July 20, 2010 | Permalink
  2. It's very possible it's your caching plugin. We've seen similar occurrences before along with some other issues.

    http://forum.gravityhelp.com/topic/not-all-entries-coming-through#post-7165

    http://forum.gravityhelp.com/topic/all_fields-dont-display-in-email#post-4250

    Also, most of the caching plugins don't show cached pages if your logged in as an admin so that might be why the form is working fine for you, but not for others.

    I'd start by disabling the caching plugin and giving it a run, see if that makes a difference.

    Posted 11 years ago on Tuesday July 20, 2010 | Permalink
  3. Interesting. There is no manual override for this problem without having the plugin disabled? I use W3 Total Cache which really speeds up my site so disabling it is not an option really. I see that the developer is planning to whitelist GF.. If I put the GF folder in my exceptions do you think that will work?

    almost forgot. Database Caching is turned off on my site

    update: I just added the following to caching exclusions and i was able to submit not being logged in

    contact/*
    wp-content/plugins/gravityforms/*

    please give it a try when you have a minute

    Posted 11 years ago on Tuesday July 20, 2010 | Permalink
  4. Hey Scott,

    2 things. Yes, the form submitted for me this time.

    screenshot

    but there is still an issue.

    We just found out that some browsers are choking on the HTML5 URL field, even if it's not set to required. The issue is that the browser expects either a full URL or nothing in the field. The default "http://" is causing it grief so without any notice or visual cue, the browser simply runs its own validation for that field type and sets the focus back on the half filled input.

    We're working on a solution for this to be included in the next release, but for the time being, you may want to replace the website field with a single line text field to avoid any problems.

    Let me know if you run into any other issue submitting the form.

    Posted 11 years ago on Tuesday July 20, 2010 | Permalink
  5. Unfortunately as Kevin pointed out, some browsers are mishandling this field by applying their own validation and not doing so in a friendly fashion. So it's a browse bug related to the HTML5 URL field type.

    The upcoming Gravity Forms v1.3.13 has an option to turn off HTML5 fields. You can then turn off the HTML5 fields.

    Gravity Forms v1.3.13 will be released via automatic upgrade later this week. If you can't wait you can download install the Beta 3 version of it from the Downloads page.

    Posted 11 years ago on Tuesday July 20, 2010 | Permalink
  6. Thanks guys!

    Posted 11 years ago on Tuesday July 20, 2010 | Permalink
  7. I have a developer's license for Gravity Forms; but, cannot get the automatic upgrade to work. Please advise. Thank you.

    Douglas W. Arnold

    Gravity Forms Version 1.3.11 New version 1.3.13.1 available. Automatic upgrade available on the plugins page

    Here is your registration key for Gravity Forms Developer License:

    [ removed ]

    Gravity Forms

    Easily create web forms and manage form entries within the WordPress admin.

    Deactivate | Edit
    Version 1.3.11 | By rocketgenius | Visit plugin site

    An error occured while updating Gravity Forms: The plugin is at the latest version..

    Posted 11 years ago on Saturday July 31, 2010 | Permalink
  8. @douglaswarnold

    WordPress released version 3.0 after we released version 1.3.11 of Gravity Forms. The new version of WP changed how automatic updates are handled. We updated the forms plugin in version 1.3.12 to work with this new system.

    That said, this time you'll need to upgrade to the newest version by downloading 1.3.13 and manually updating the plugin via the built in uploader or via ftp.

    Posted 11 years ago on Saturday July 31, 2010 | Permalink
  9. Kevin,

    Thank you very much!

    <peace>Doug</peace>

    Posted 11 years ago on Saturday July 31, 2010 | Permalink