PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

CSS customization assistance needed for Gravity Form widget

  1. Hey Kevin, Carl!

    I'm trying to tighten up the GF widget on my Headway-powered site.

    It's coming out really, really loose - taking up acres of page real estate down the page on the right hand side.

    Can you suggest how I can fix it so it's super-tightened up across all the fields? I'd like to keep the First Name, Last Name fields rather than just the Simple Name option if possible.

    A link to the page and the site:

    http://www.thepodcastguy.com

    Thanks for your excellent work!

    Dave Thackeray

    Posted 10 years ago on Friday November 26, 2010 | Permalink
  2. It's inheriting some extra margins and spacing from your theme. You can try adding this to your custom CSS

    li.widget.gform_widget ul li {margin:0!important; line-height:auto!important}
    li.widget.gform_widget ul li.gfield input,li.gform_widget ul li.gfield textarea{margin-bottom:0!important}
    li.widget.gform_widget .gform_footer {padding:0!important}

    That should tighten it up quite a bit. You can tweak it a little more if you need.

    Posted 10 years ago on Friday November 26, 2010 | Permalink
  3. Thanks for your help with this. It's looking better already!

    Dave

    Posted 10 years ago on Friday November 26, 2010 | Permalink
  4. This worked brilliantly for me too except the submit button is now up beside the bottom fields instead of underneath. Any suggestions?
    You can see the form here - http://wordpresswebsites.co.nz/WebStrategies/

    Posted 10 years ago on Monday February 28, 2011 | Permalink
  5. I have got the button underneath again so am working on trying to reduce the margin above it now.

    Posted 10 years ago on Monday February 28, 2011 | Permalink
  6. I am pretty much there. Added the following code to my Genesis child theme style sheet. Would still like to get rid of a wee bit more space above but not essential.

    body .gform_wrapper .gform_footer {
        float: left;
        margin: 0px 0 0 10px!important;
        width: auto;
    }
    Posted 10 years ago on Tuesday March 1, 2011 | Permalink
  7. You need to remove the top & bottom padding from the gform_footer div that contains the button. Try adding this to the end of your theme's style.css file or wherever you add custom CSS

    body #gform_wrapper_1.gform_wrapper .gform_footer.right_label,
    body #gform_wrapper_1.gform_wrapper .gform_footer.left_label {
        padding: 0 0 0 31%;
    }

    Also, you might consider using the "large" field option on all of your fields so they display more uniformly. Just my opinion.

    test screenshot: http://grab.by/9dSL

    Posted 10 years ago on Tuesday March 1, 2011 | Permalink