PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

CSS not loading and selectors not editing

  1. KindraPB
    Member

    I'm having two issues at the moment and they may or may not be connected, but I'm really stumped here with both of them so I will include both.

    First off, my form is not styling properly on certain client websites. It works on some, so I know it has the capability to be awesome. Here is one of the client websites that it is not formatting http://ricelakewis.com/visitor-guide/. Upon further investigation, I noticed that forms.css was blank when I went into Firebug. I copied everything into my style.css file and the form looked how it should, but I really don't want to add that to an already lengthy file. So my next step was to go into wordpress and check out what was going on with forms.css. When I went into the front-end editor in WordPress plugins, I found that forms.css was inactive, but there was no button anywhere to activate it. I tried enqueueing the file in the header before wp_head given in some help topics and that did not work either. Deactivating all other plugins also didn't work. So now I'm stumped as to what to try on that.

    The second issue that I've been having on these sites is that I'm unable to add or edit the checkboxes, or radio buttons, or drop down menus. I select the edit link in the form and it doesn't do anything (no loading, nothing, just sits there). I've tried saving, deleting the form, creating a new form, and none of these solutions seem to work. I also haven't seen this documented anywhere, so hopefully someone can clue me into the problems I'm having.

    Posted 8 years ago on Tuesday December 13, 2011 | Permalink
  2. Hi Kindra,

    The blank forms.css is an odd issue. If you open up the file via FTP does it have any content? If not, there is a just that something simply went wrong during the installation. Try deleting Gravity Forms and then reuploading it.

    The inability to edit checkboxes, radio buttons and drop down menus is likely a javascript error. Try following these directions to determine if this issue is being caused by a theme or plugin conflict.

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Let me know the verdict. :)

    Posted 8 years ago on Tuesday December 13, 2011 | Permalink
  3. Looks like a bad installation. Why is the forms.css referenced in a folder called gravityforms2? Also, it's not present there or in a folder called gravityforms. It just looks like a bad installation. I would completely uninstall the plugin if you can afford to lose all the data and all your forms. If not, then don't uninstall. But it looks like something went wrong with the installation, at least once.

    Posted 8 years ago on Thursday December 15, 2011 | Permalink