PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

CSS styles on form

  1. Hello everyone - I have a test site and a form at
    http://j74.net/contact/
    There are arrows on each of the form elements even though I added this to the bottom of the main stylesheet

    [css]
    body .gform_wrapper form .gform_body ul,
    body .gform_wrapper form .gform_body ul li {
    	list-style-type:none!important;
    	list-style-image:none!important;
    	list-style:none!important;
    	background-image:none!important;
    	background:none!important;
    	padding:0!important;
    	margin:0!important
    }

    Any help with this will be appreciated. Thanks !! Regards - Mal

    Posted 9 years ago on Wednesday September 14, 2011 | Permalink
  2. I checked 3 browsers and don't see any bullet images/arrows. It looks like your styles are being applied.

    screenshot: http://bit.ly/qqjVgI

    Try clearing your browser cache and see if that helps out.

    Posted 9 years ago on Wednesday September 14, 2011 | Permalink
  3. No arrows here in Chrome on Linux.

    Posted 9 years ago on Wednesday September 14, 2011 | Permalink
  4. You were right about the cache. On both my Mac and PC. I rebuilt the form several times and I'm still having display problems with some of the fields. Although it looks the same on all the browsers I used. I'll test it later on Adobe Browser Labs. I can use another contact form on this site to get it launched but I want to get Gravity working on it perfectly moving forward do build online applications. Any idea on the latest display prob where the phone and email fields do not have any background?

    Best Regards, Mal

    Posted 9 years ago on Wednesday September 14, 2011 | Permalink
  5. Yeah, I noticed but I forgot to mention that earlier, I didn't inspect your CSS to be sure, but I'm guessing that you have the "output HTML5" option on and I'm sure that your theme CSS has applied the border style to the text input type ( input[type=text] ) specifically.

    The thing is, if that the email and phone fields are new input types ( tel and email ) in HTML 5 so you'll need to add them to that rule. You can locate the rule in your styles that adds the border, then add these in as well.. something like this.

    [css]
    body .gform_wrapper input[type=tel],
    body .gform_wrapper input[type=email] {
        border: red;
    }
    Posted 9 years ago on Wednesday September 14, 2011 | Permalink
  6. You The Man !! Thanks Kevin.

    Best Regards, Mal

    Posted 9 years ago on Thursday September 15, 2011 | Permalink

This topic has been resolved and has been closed to new replies.