PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

CSS styling yuk

  1. AngelinaC
    Member

    Hi Carl, Thanks, overall its shaping up to be a very nice component! Thanks.

    PLEASE if you could help with a couple quick questions:

    the css of the site is putting in horrible line rules under every item in the layout.

    The manual says:

    CSS Class Name
    Enter the CSS class name you would like to use in order to override the default styles for this form.

    Is there some included css class so a basic appearance is achieved out of the box, but that we can override the site theme? It looks dreadful - and this is such a rush project ...
    a plain white background looks great - on a different template I have on the staging site.

    ANY HELP IS GREATLY APPRECIATED!

    also we bought the version -but the install says to buy support....(i do have installed on the staging website and the live site - that may be the prob?)

    I'm having trouble getting the form to appear on a post - but it works fine on a page - is that the only option.

    I've worked with wordpress for two whole days now - I appreciate your patience with me!

    Posted 9 years ago on Friday October 1, 2010 | Permalink
  2. The default styles aren't intended to completely override the theme styles, they're actually designed to inherit some styles from the them itself. Without seeing the theme and what your issues are, it's difficult to give you any kind of guidance on how to fix them.

    The form should work on either posts or pages, anywhere you can add content via the WYSIWYG editor, you should be able to add the form via a shortcode. You can also add the form via the built-in widget component or elsewhere in your theme via a php function call. You can get more details on that on the page linked below.

    http://www.gravityhelp.com/documentation/embedding-a-form/

    Posted 9 years ago on Friday October 1, 2010 | Permalink
  3. If you installed the plugin and are seeing the "Please Purchase Gravity Forms" message in the WordPress admin then you need to make sure you have entered your license key correct on the Settings page of Gravity Forms (Forms > Settings) and then save the settings. This will then validate your license key. If you have done this and it still doesn't work then get in touch with us via our Contact Us form and supply a WordPress admin login to the site having the problem and we can take a look.

    Posted 9 years ago on Friday October 1, 2010 | Permalink
  4. AngelinaC
    Member

    It isn't published to where it will be, but it looks like you can access it:

    http://marketresearchbulletin.com/?page_id=1789

    I entered the key - so it took down the "buy this" message. Thanks!

    Posted 9 years ago on Friday October 1, 2010 | Permalink
  5. Cool. Easy styling fix. You can append this rule to the end of your style.css file and it should remove the bullet image background and the bottom border from the containing list item.

    .gform_wrapper li, .gform_wrapper form li, .gform_wrapper form ul li { list-style-type:none!important; background-image:none!important; border-bottom:none!important}

    test screenshot

    Posted 9 years ago on Friday October 1, 2010 | Permalink
  6. AngelinaC
    Member

    Wow!! Kevin - THANKYOU!!!! AWESOME. It looks great.

    This template is striking me as a little odd, but probably because I don't know wordpress well.

    Like on the articles - any time you put in an element, the template places a line rule - like in the form.

    http://marketresearchbulletin.com/?p=1760

    This is above and beyond to ask you, but could you give me an idea of what to search on to find this fix. The template maker's website hasn't answered questions in a couple days now - I'm unfamiliar with wordpress terminology - and if you don't know what to call it - you won't find it in a search engine!

    I have to say thank you to your whole team, this product worked great and the support was fantastic. Have a great weekend!

    Posted 9 years ago on Saturday October 2, 2010 | Permalink
  7. Sure, if you look at your theme's style1.css file on line 220 you'll see this rule

    .sidebar .box li a,  .box .recentcomments, .entry ul li {
    background:transparent url(../images/skin1/bullet1.png) no-repeat scroll 0 12px;
    border-bottom:1px solid #D6D6D6;
    }

    If you remove the "border:bottom" property, that would should fix your issue. It's adding the bottom border to any unordered list item. The problem is, that's also adding the borders to the sidebar elements where I'm sure you would want them.

    The better way is to add something like this to the end of your style sheet to override the original rule.

    .entry ul li {border:none!important}

    test screenshot

    Hope that helps out. Thanks too for the kudos. We try really hard to offer great support.

    Posted 9 years ago on Saturday October 2, 2010 | Permalink