PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Custom post fields don't show

  1. I've just bought Gravity and don't seem to be able to get custom field data to show in a post. I will be using the form for property rental post creation whereby advertisers will be able to pay, complete the form and for me to check and publish. I've created a couple of spoof custom fields and ensured I've got a title and/or body but the custom fields don't show, any thoughts would be appreciated.
    Nick Garnett

    Posted 9 years ago on Wednesday March 24, 2010 | Permalink
  2. Hello Nick, we would need a WordPress Admin login for this site in order to look at your form settings and run some tests. You can send this to us via the Contact Us form on this site and reference this forum post.

    Posted 9 years ago on Wednesday March 24, 2010 | Permalink
  3. I've sent admin login's by contact form - URL is http://www.french-holiday-homes.co.uk/wordpress/wp-admin

    Posted 9 years ago on Thursday March 25, 2010 | Permalink
  4. I just checked out your Gravity Forms setup and it is saving the custom field data just fine. If you edit any of your test posts and look at the Custom Fields area you will see that the data exists and is there.

    The problem is you aren't displaying those custom fields in your theme template file. You have to tell your theme to output the custom fields and where to display them. Right now they aren't being displayed because the theme isn't telling them to be displayed.

    You will have to read up on how to use and display custom fields in your theme.

    Here are some good resources:

    http://codex.wordpress.org/Custom_Fields

    http://vandelaydesign.com/blog/wordpress/custom-fields/

    Posted 9 years ago on Thursday March 25, 2010 | Permalink