PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Data entry fields (boxes) won't display

  1. Newbie here... My designer just installed a new design using Thesis and the data entry boxes won't show up in Chrome, Firefox & Safari. (I'm using WP version 3.0.4.)

    See: http://equalfooting.org/donate-laptop/ and http://equalfooting.org/featured-volunteer/

    To the kind soul(s) that help me with this, I know a bit of code and know my way around WP, a little, but I'm no pro.

    Thanks.

    Posted 8 years ago on Tuesday January 18, 2011 | Permalink
  2. The problem is with the custom CSS rules your designer has added. Line 540 of the custom.css file sets the border width on the inputs to 0. Thats why you don't see the input areas defined.

    .format_text .dd_content_wrap input, .dd_content_wrap #commentform input, .dd_content_wrap #commentform textarea {border-width: 0em;padding: 0.188em; width: 45%;}

    If you disable/remove the "border-width:0em" property, you'll see that the inputs appear normally

    screenshot: http://grab.by/8rCT

    Posted 8 years ago on Tuesday January 18, 2011 | Permalink
  3. Thanks. I'll pass the info along.

    Posted 8 years ago on Tuesday January 18, 2011 | Permalink
  4. Kevin -

    I implemented the solution you advised. It solved the problem in Firefox, but the fields are still not displaying correctly in IE, Chrome and Safari. Some of the fields display in those browsers, others don't.

    Please advise.

    Posted 8 years ago on Wednesday January 19, 2011 | Permalink
  5. Yeah, it's more border width weirdness coming from your theme - line 243 of the layout.css file.

    Try adding this to the end of your custom.css. This should override the weird border value and reset it to the browser defaults.

    body .gform_wrapper .gform_body .gform_fields .gfield input[type=text],
    body .gform_wrapper .gform_body .gform_fields .gfield input[type=email],
    body .gform_wrapper .gform_body .gform_fields .gfield input[type=url],
    body .gform_wrapper .gform_body .gform_fields .gfield input[type=password],
    body .gform_wrapper .gform_body .gform_fields .gfield input[type=tel],
    body .gform_wrapper .gform_body .gform_fields .gfield select,
    body .gform_wrapper .gform_body .gform_fields .gfield textarea {border-width:auto!important}
    Posted 8 years ago on Wednesday January 19, 2011 | Permalink
  6. stephan.wehmeier
    Member

    I have a similar problem with the input boxes: they won't show up.
    My guess is that some code of the Themes CSS is making trouble. But I have no idea where to start. I would be glad if someone had suggestions how to solve this.
    Thanks.

    URL to the form page: http://www.ju-bergkamen.de/kontakt/

    Posted 8 years ago on Wednesday January 26, 2011 | Permalink
  7. Your theme's style.css file (line 12) has a rule that removes border from ALL elements - this is affecting your form inputs as well. If you disable/remove that, you'll see that the form inputs show up normally.

    screenshot: http://grab.by/8AiH

    Posted 8 years ago on Wednesday January 26, 2011 | Permalink
  8. stephan.wehmeier
    Member

    That worked.
    In the end I had to use a different approach, because the "border: none" rule is necessary for the correct displaying of images that are links as well. I simply added a border attribute to the input wrapper.
    Thanks a lot.

    Posted 8 years ago on Wednesday January 26, 2011 | Permalink
  9. That works. Glad you got it fixed up.

    Posted 8 years ago on Wednesday January 26, 2011 | Permalink