PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Database Error After Activation

  1. I just installed and activated the plugin for the first time on our development site, and got these errors (I replaced someone of the actual info with what it was in brackets):

    WordPress database error: [Table '[subdomain]_[domain]_c.[prefix]_rg_form_meta' doesn't exist]
    SHOW INDEX FROM [prefix]_rg_form_meta WHERE Key_name='form_id'

    WordPress database error: [Table '[subdomain]_[domain]_c.[prefix]_rg_lead_detail_long' doesn't exist]
    SHOW INDEX FROM [prefix]_rg_lead_detail_long WHERE Key_name='lead_detail_key'

    The site is in WordPress 3.2.1 on a server with PHP 5.3 and MySQL 5.

    Do you know what this is?

    Posted 9 years ago on Tuesday November 8, 2011 | Permalink
  2. Also, please consider using a generic avatar that is gender neutral.

    Posted 9 years ago on Tuesday November 8, 2011 | Permalink
  3. It looks like necessary database tables and associated table columns weren't created.

    I would suggest uninstalling Gravity Forms by going to the Settings page under Forms and then choosing Uninstall.

    Then make sure the database user configured in your wp-config.php file that your WordPress site uses has ALTER permissions. That user really needs FULL permissions. It needs to be able to create new tables.

    Then I would suggest re-installing Gravity Forms.

    If this issue happens again then you may need to contact your web host. That is a database error related to columns not existing.

    Posted 9 years ago on Tuesday November 8, 2011 | Permalink
  4. The avatar is a placeholder. If you want to customize your avatar, configure one at http://www.gravatar.com and associate it with your email address and it will automatically be used.

    Posted 9 years ago on Tuesday November 8, 2011 | Permalink