PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Date Picker giving invalid date

  1. I selected the date picker, set the style. When it's live and you pick a date it will put 7 Mar, 13 as the result but then when I submit, it says the date must be dd/mm/yyyy, which is what I picked but the output is different. Why? What setting am I missing?

    Posted 6 years ago on Thursday March 14, 2013 | Permalink
  2. Please provide a link to the page on your site where we can see your form and the date picker. Thank you.

    Posted 6 years ago on Sunday March 17, 2013 | Permalink
  3. I selected March 29, 2013, but in the field it wrote 29 Mar, 13. Did you add code to make that happen? If not, it looks like it's a plugin or theme conflict with the datepicker, something else setting that date format.

    What date format did you select in the form builder (screenshot please?)

    Also, if you submit this form from the form preview, is the date format correct there?

    Posted 6 years ago on Tuesday March 19, 2013 | Permalink
  4. I did notice that your theme is including this jQuery UI script:

    <script type='text/javascript' src='http://paradise.socialmediaambassador.com/wp-content/themes/Lamoon/scripts/jquery-ui-1.8.22.custom.min.js?ver=1.0'></script>

    But Gravity Forms is already including this version:

    <script type='text/javascript' src='http://paradise.socialmediaambassador.com/wp-content/plugins/gravityforms/js/jquery-ui/ui.datepicker.js?ver=1.6.12'></script>

    Maybe there is a conflict there. You can check for theme and plugin conflicts by using these instructions http://rkt.gs/testing

    Posted 6 years ago on Tuesday March 19, 2013 | Permalink
  5. There is a conflict. I switched themes previously and something else worked. Here is the screenshot you asked for. http://awesomescreenshot.com/00512e7xf9

    With those two versions is there a way to change something to make it work?

    Posted 6 years ago on Tuesday March 19, 2013 | Permalink
  6. David Peralty
    Administrator

    Can you edit your theme's header.php file and comment out the version of jquery UI that they are using?

    Posted 6 years ago on Tuesday March 19, 2013 | Permalink
  7. Yes, but how can I be sure that won't mess up their features?

    Posted 6 years ago on Monday March 25, 2013 | Permalink
  8. David Peralty
    Administrator

    You can't, but that's the only option you have other than contacting the developer of the theme to figure out what they can do about the conflict.

    Posted 6 years ago on Monday March 25, 2013 | Permalink