PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Default Confirmation Not Working

  1. martindale
    Member

    Updated to 1.7, unable to get the Default Confirmation Text nor a Redirect to /thank-you/ to work on my site. Newest version of WordPress, I even disabled the only few plugins I had which were Akismet, Disquis, & MapPress Easy Google Maps and tried again to see if any of those were messing anything up.

    You can see the form @ http://shc.iamfrankstallone.com/support/ticket/

    Posted 6 years ago on Wednesday April 24, 2013 | Permalink
  2. It looks like there are a couple of jQuery is undefined errors on that page, most likely because jQuery is being included in the footer, rather than in the head of your page which Gravity Forms requires.

    Try testing your form within the form builder preview window and also by using a default WP theme.

    Posted 6 years ago on Wednesday April 24, 2013 | Permalink
  3. martindale
    Member

    Yes, I call jQuery in the footer, isn't that performance 101? =)

    Posted 6 years ago on Wednesday April 24, 2013 | Permalink
  4. martindale
    Member

    Is this new with 1.7? I have never had an issue with 1.6, jQuery in the footer, and forms working fine.

    Posted 6 years ago on Wednesday April 24, 2013 | Permalink
  5. It's nothing new, it's just safer to use in the head with Gravity Forms. There are certain aspects that require it to be in the head. Would you mind humoring me to see if that solves it? Or could you try in the formbuilder preview window for me and let me know if it works? Can you try without AJAX enabled on your form shortcode?

    Just trying to help and get to the bottom of this, so if you could try those things above that would be most appreciated.

    Posted 6 years ago on Wednesday April 24, 2013 | Permalink
  6. martindale
    Member

    Rob, yes and I appreciate that. I am sure your right. When I put jQuery back in the header though I get uncaught TypeError: Property '$' ... errors -- basically it's having trouble finding jQuery now. Was just trying to solve it with moving jQuery back to the head but I caused other problems.

    Taking out ajax="true" from shortcode fixed the issue. I imagine if jQuery is loaded above Gravity Forms js the Preview Window will work too.

    Posted 6 years ago on Wednesday April 24, 2013 | Permalink