PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Duplicated Forms Not Saving v1.2.2

  1. Updated to v 1.2.2 and ran into an issue when I duplicated a form.

    After duplicating, I changed the name of the form, added new fields (drop-downs, multiple choice, etc.) and then "Update Form".

    When I clicked Preview, it was blank with error message "Oops! We could not locate your form." When I went back to edit the form, all fields were missing.

    I tested this twice. Both with same results.

    Posted 9 years ago on Wednesday October 21, 2009 | Permalink
  2. Kristof,
    If you just duplicate the form and then preview it (without adding any fields or changing the title), does the preview load correctly? If so, then your issue is not related to the form duplication, but probably related to the text you are entering in the title or those new fields.

    Could you do me a favor to help us troubleshoot this?
    Next time that the form has this issue, run the following sql statement in phpMyAdmin (replacing XXX with your form id):
    select display_meta from wp_rg_form_meta where form_id=XXX
    You can send me the results to alex[at]rocketgenius.com

    Posted 9 years ago on Wednesday October 21, 2009 | Permalink
  3. I believe I found the problem.

    I added new multiple choice field with following 3 options;
    6" x 9" (club)
    8.5" x 11" (Standard)
    8.5" x 14" (Legal)

    When I tried to preview the form after updating, the form was empty.

    I believe the issue lies with including " (inch marks). When I went back to edit, all text after the last " was missing.

    When I deleted the multiple choice field, the form displayed.

    I also created a new multiple choice field where I used parenthesis but no inch marks and everything worked.

    Since almost every form on my site needs to include size options, I need to use the inch symbol. And because the text for multiple choice options can't run onto two lines (something I wish you would look into correcting) I can't spell it out as "inches" -- some of the options require longer descriptions.

    Posted 9 years ago on Thursday October 22, 2009 | Permalink
  4. Hey Kristof, I created a test form using a multiple choice that contains exactly what you referenced above (I cut-n-paste from your post above to create the values) and was able to save and preview the form.

    Would it be possible to get a login to the WordPress site where this is happening so we can see it happening first hand and debug the issue?

    Posted 9 years ago on Thursday October 22, 2009 | Permalink
  5. Hi Carl -

    I'm using GF locally (MAMP) on a site-in-progress. Any other thoughts on how I can test/send you results?

    Posted 9 years ago on Friday October 23, 2009 | Permalink
  6. Kristof, the first thing to do in testing anything is to determine if there is a plugin conflict by deactivate all other plugins. We had a similar issue recently that turned out to be a conflict with the WPML plugin.

    Do this:

    Step 1. Activate ONLY Gravity Forms and test it to see if it works properly. If it does proceed to Step 2.

    Step 2. Activate plugins one by one, AFTER EACH one you activate you need to test Gravity Forms for the issue you are reporting above.

    After activating each plugin one by one and then encountering an issue with Gravity Forms, you would be experiencing a plugin conflict. If this is what is happening, let us know which plugin caused the conflict so we can check it out on our end.

    If it is not a plugin conflict you will have to test the site on an actual web host to determine if it's an issue caused by your MAMP environment. If it can be replicated on a web host then you can give us access to it in order to debug the issue further.

    I'm leaning towards another plugin causing an issue, because it is similar to the WPML conflict we just encountered. But I could certainly be wrong.

    Posted 9 years ago on Friday October 23, 2009 | Permalink