PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Dynamic Population With Query Strings Not Functioning

  1. I'm trying to use Query Strings here:
    http://10secrets.heliopower.com/secret-1/

    This page will only be seen by existing subscribers, so we want the form to auto fill with their data should they want to take the next step with us. We'll already have the name and email, we will want the phone number from them. So we want the name and email to auto-fill from the URL we've sent them in their email.

    I've got the dynamic field population setup: http://cl.ly/image/003d2W2p0Q11

    But when I try the following:
    http://10secrets.heliopower.com/secret-1/?name=Scott&email=SGordon@HelioPower.com
    or
    http://10secrets.heliopower.com/secret-1/?name=Scott

    I get a 404 error.

    Posted 7 years ago on Thursday March 14, 2013 | Permalink
  2. 'name' is a reserved parameter name. Try changing that in both places to "fname" or 'firstname' or something else other than just 'name'. I think it will work at that point.

    Posted 7 years ago on Thursday March 14, 2013 | Permalink
  3. You Sir... are a genius.

    And here I thought I had broken the whole system.

    Thanks.

    I would suggest adding the info about reserved names to the documentation page for the Query Strings. :)

    Posted 7 years ago on Thursday March 14, 2013 | Permalink
  4. I've never found clear documentation on the word "name" being reserved in WordPress query strings. Oh wait: maybe this is it: http://codex.wordpress.org/Function_Reference/register_taxonomy#Reserved_Terms

    I added the note to this documentation page:
    http://www.gravityhelp.com/documentation/page/Using_Dynamic_Population#Getting_Started

    Are there other documentation pages you read which would benefit from a similar addition?

    Posted 7 years ago on Thursday March 14, 2013 | Permalink