PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Email Notification Doesn't Work

  1. alexgold
    Member

    I have setup 2 forms with email notification, but no notification is sent upon submitting test forms. I have checked my spam filter to ensure that wasn't the issue. The emails are just not being sent. Please help.

    Posted 10 years ago on Saturday November 5, 2011 | Permalink
  2. Alex, mail delivery is a surprisingly complex topic and it always comes down to configuration on one end or the other. Good reading from Joost de Valk:
    http://yoast.com/email-reliability/

    One thing that seems to work reliably is the WP Mail SMTP plugin, to deliver mail via SMTP rather than wp_mail().
    http://wordpress.org/extend/plugins/wp-mail-smtp/

    Posted 10 years ago on Saturday November 5, 2011 | Permalink
  3. alexgold
    Member

    Rob, thanks for the information I read the article, updated my SPF records accordingly, and I installed WP Mail. Unfortunately, WP Mail keeps erroring out as follows, despite the fact I've configured it exactly the same way as my email client:

    SMTP -> ERROR: Failed to connect to server: Connection timed out (110)

    SMTP Error: Could not connect to SMTP host.

    Any help to get this working properly would be much appreciated.

    Posted 10 years ago on Saturday November 5, 2011 | Permalink
  4. This is most likely a web server configuration issue. Did you verify your port is correct in the settings and matches your host's settings?

    Posted 10 years ago on Sunday November 6, 2011 | Permalink
  5. alexgold
    Member

    Hi Rob, what is a "correct" port please? I'm using the same port that works fine for my email client. Should I use a different one for Wordpress/Gravity Forms? Thanks for your help.

    Posted 10 years ago on Monday November 7, 2011 | Permalink
  6. You may need to contact your host to verify you are using the correct port and/or if it's being blocked by a firewall so they can open it up. I came across this tool that might help you to see if it is being blocked or not.

    Posted 10 years ago on Monday November 7, 2011 | Permalink
  7. alexgold
    Member

    Rob,

    I don't see a link to a tool?

    Also, this is way above my level, so can you please tell me exactly what I should ask my host? I am asking them "What is the correct port for _________ ?"

    Thanks,
    Alex

    Posted 10 years ago on Monday November 7, 2011 | Permalink
  8. Ah, sorry about that one! Here is the link:

    http://www.alicka.com/tools.html

    You're going to check about the SMTP port.

    Posted 10 years ago on Monday November 7, 2011 | Permalink
  9. alexgold
    Member

    I have confirmed the SMTP port, I was indeed using the correct one. Still no notification emails from Gravity Forms. Please help.

    Posted 10 years ago on Tuesday November 8, 2011 | Permalink
  10. alexgold
    Member

    P.S. I am using BlueHost. I notice on several other posts that GoDaddy is a serious problem, but that's not the case here.

    Indeed, I have successfully sent emails from a WordPress install on BlueHost using other, more basic contact forms than GravityForms and they worked fine. I like GravityForms much better in theory, but so far zero success on the email notifications.

    Posted 10 years ago on Tuesday November 8, 2011 | Permalink
  11. travin
    Member

    I am also using Bluehost and have a similiar problem. My email gets sent but the "from email address is not the one I selected it to send. It sends the email from "freecla3@box721.bluehost.com" instead of noreply@paylaterproducts.com.

    Posted 10 years ago on Tuesday November 8, 2011 | Permalink
  12. alexgold
    Member

    I would be OK with it sending from a weird email address, right now it's not sending at all. The SMTP appears to be configured properly, and I added the recommended SPF record to my DNS. So, as far as I can tell everything is setup as it should be. But it's not working...

    Posted 10 years ago on Tuesday November 8, 2011 | Permalink
  13. Are you still receiving this error message?

    SMTP -> ERROR: Failed to connect to server: Connection timed out (110)
    
    SMTP Error: Could not connect to SMTP host.

    If so then no, your SMTP settings are not configured properly OR you have a web hosting problem. That error message is a server error. It can't connect to the SMTP server using the settings you configured.

    After you configure the SMTP settings in WP Mail SMTP you will need to use the Test Email functionality that is included on the Settings page of the WP Mail SMTP plugin. It will let you send a test email. See if that email arrives.

    If it does, then you need to make sure your notifications are properly configured. You must set the SEND FROM address on the notifications to an email address that is associated with your SMTP account. You can't use any email address here, it has to be one associated with that SMTP service.

    Gravity Forms doesn't send the emails, your web server does. So any issues related to email notifications not being sent are going to be related to 1) your web server configuration 2) what you are using in the send from address for your notifications and 3) your smtp settings if using the WP Mail SMTP plugin.

    @travein You need to discuss this with bluehost. That is a hosting configuration issue. We used to host with BlueHost and had a similar issue, we contacted and discussed it with them and they had it resolved.

    Posted 10 years ago on Tuesday November 8, 2011 | Permalink
  14. alexgold
    Member

    Hi Carl,

    The failure is on the test send, as well as the notifications. I configured the plugin Rob recommended (WP Mail SMTP) exactly as my email client is configured. I then confirmed that I am using the correct port with Bluehost per Rob's suggestion, and I am using the correct port. This is not working. Without notification, Gravity Forms isn't much use, so I would greatly appreciate specific steps to fix this.

    Thank you,
    Alex

    P.S. If you would like the complete results of the test send, I would be happy to forward them. There may be something in there that will help you understand, but it's all Greek to me. Thank you.

    Posted 10 years ago on Tuesday November 8, 2011 | Permalink
  15. If the failure is on the test send then the SMTP settings aren't correct. If the SMTP settings were correct then the test send would work. You'll need to explain this to BlueHost that the SMTP settings appear to be incorrect, walk them through what settings you have in place and then tell them exactly what error you are getting. The issue is definitely related to your SMTP settings. If they were correct, the test email would work.

    Posted 10 years ago on Tuesday November 8, 2011 | Permalink
  16. I placed the following test code in a template to verify that wp_mail works.

    <?php wp_mail('me@example.net', 'The subject', 'The message'); ?>

    I changed the email address to my own but I will not in this post to protect myself from spam.

    However, my notifications are not working at all. wp_mail itself works, but notifications do not. Any ideas?

    Posted 10 years ago on Thursday November 17, 2011 | Permalink