PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Email Notification Issue

  1. arlyon
    Member

    I've read several other posts on this topic, but without finding a solution.
    My emails notifications aren't arriving to the admin email address. They are appearing in "entries" in the WP admin, but no email notification.
    I've deactivated all plugins - not the problem.
    I checked the theme - not the problem (using Genesis).
    Suggestions?

    Posted 9 years ago on Wednesday December 5, 2012 | Permalink
  2. As far as notifications go, Gravity Forms does not actually send the email notifications. That is 100% handled by your web server. Gravity Forms uses the WordPress wp_mail() function, a built in WordPress function, to ask your web server to send the email notification.

    This can happen when you do things such as configure the Send From address of email notifications to an email address that does not use the same domain name as the web site itself. Also, sometimes they can get spammed. Have you ruled these out already?

    After that, it is entirely up to your web server to reliably send the email. Unfortunately, many web hosts are simply unreliable at handling email properly when sent via PHP. This results in unreliable performance.

    The most reliable way to configure WordPress to handle sending email is going to be to use SMTP. You would do this by installing the WP Mail SMTP plugin and then contacting your web host to get the appropriate SMTP settings. You would then need to configure the Send From of your notifications so that it uses an address associated with that SMTP account.

    http://wordpress.org/extend/plugins/wp-mail-smtp/

    Posted 9 years ago on Wednesday December 5, 2012 | Permalink
  3. arlyon
    Member

    Thanks Rob. I ruled out spam, but didn't rule out the non-matching domain and email. That could very well be the problem. Thanks for the response.

    Posted 9 years ago on Wednesday December 5, 2012 | Permalink