PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Email Notifications

  1. My forms had been working fine until recently. At first, it seemed like they had stopped working completely, but after some testing, I noticed that they worked fine as long as the sender's email have the domain pleasantonusd.net, which is the domain for the Google Apps email system we are using. It doesn't matter what the jsmith@ part is, as long as the domain is pleasantonusd.net the email goes through.

    I am hosting the site on a remote server. The WP general settings email and the server's admin email are both my private email account which doesn't have anything to do with pleasantonusd.net. The CIMY Swift SMTP plugin is set up for the server with the SMTP server address: mail.amadorvalleyhs.org, Port: 465, Username: postmaster@amadorvalleyhs.org.

    Since pleasantonusd does not seem to be in the picture in any of these variable, is there anywhere else where I may have inadvertently plugeed in some kind of formula or routing algorhythm? I've checked the form itself and I don't seem to see anything there. (Note: I do have the code you provided for automatically deteling entries in the functions.php file.)

    Thanks,

    Erik

    Posted 7 years ago on Wednesday March 13, 2013 | Permalink
  2. David Peralty

    Sounds like another plugin might be hijacking things? If you are using SMTP, what settings do you have for that? Can you try the following troubleshooting steps please? http://www.gravityhelp.com/documentation/page/Troubleshooting_Notifications

    Posted 7 years ago on Wednesday March 13, 2013 | Permalink
  3. I turned off all plugins, switched to the 2010 theme and did everything else that was recommended, although I have not yet heard back from my host provider.

    Here are the smtp settings:

    never overwrite the sender
    smtp server address: mail.amadorvalleyhs.org
    port: 465
    ssl

    Posted 7 years ago on Wednesday March 13, 2013 | Permalink
  4. David Peralty

    You'll probably have to wait to hear from your host because there isn't much we can do about notifications, as we just pass details to WordPress, and then it uses sendmail, or in your case, a SMTP plugin. Something is causing the issue, and you've looked through all the common culprits. Hopefully, you'll hear back from them soon. All my best!

    Posted 7 years ago on Wednesday March 13, 2013 | Permalink
  5. I guess the nagging question is why does it work with one particular domain (pleasantonusd.net) and not others. Since the host is not associated with the domain, I would think that the problem is something that I am doing with Gravity Forms. Could there be something that I did on the form side that is causing this mistake to happen?

    Posted 7 years ago on Wednesday March 13, 2013 | Permalink