PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Email notifications not arriving

  1. Hi there - Love GravityForms so far but am not getting email notifications. Yes, I've double-checked my setup and reviewed your support page with the instructions for setting up the page. And I've double-checked that the "to" email address is accurately typed.

    Unless I can get this to work, I can't use GravityForms. Any ideas about what I should try next? Thanks!

    Posted 12 years ago on Thursday August 27, 2009 | Permalink
  2. We will do what we can to help with this issue.

    Gravity Forms uses the WordPress mail function to send emails, are the other email notifications from WordPress working just fine? User registration, comment subscription, etc.

    Also, some hosts control how email is handled. Let me know a little bit more about your hosting setup, who you are currently using for hosting, etc. and we will figure out why the email is not sending and get things working. Every host is different with how things are configured so it is probably something simple, we just have to determine the cause.

    Posted 12 years ago on Thursday August 27, 2009 | Permalink
  3. @lenski was able to get this resolved, I'm guessing it was a hosting configuration change. Hopefully she will post what the resolution was shortly.

    Posted 12 years ago on Thursday August 27, 2009 | Permalink
  4. FYI - I'm having same issue but think it's due to developing site locally using MAMP.

    Posted 12 years ago on Thursday August 27, 2009 | Permalink
  5. Hi, Carl - It took a bit of hair pulling, but here's what it was -- and it was nothing whatsoever to do with GravityForms.

    It turns out that I had a setting in Plesk (I host with MediaTemple) that caused Horde webmail (which I never use) to hang on to any email sent to me by me. So, since I set the form notification "to" email address as mine, and WordPress uses the same address for my admin, nothing was coming through. Once I turned off that Plesk setting, everything worked like a charm.

    Hope my experience can be useful to help someone else!

    Your plugin totally rocks, BTW.

    Posted 12 years ago on Thursday August 27, 2009 | Permalink
  6. Thanks lenski!

    Gravity Forms uses the built in WordPress mail function and is completely at the mercy of your server settings as far as how it handles sending the email.

    I know with BlueHost you have to register the email in your cpanel so it will allow it to send with that address. It's a bit of a pain but they do it for security reasons and to help limit people using their services to send spam.

    Posted 12 years ago on Thursday August 27, 2009 | Permalink
  7. gradyclouse
    Member

    I am having the same problem, compounded because we use Google Apps for email. Our hosting provider can only send email via Port 25, which Google does not support.

    Does anyone know whether there is a setting within WordPress that controls choice of SMTP server? I know sending email ostensibly from one domain via a different SMTP server presents its own issues, but I'd like to know if it's an option. Thanks.

    Posted 12 years ago on Tuesday September 22, 2009 | Permalink
  8. @gradyclouse There are a variety of plugins for WordPress that implement SMTP and override the standard WordPress mail function.

    You can check out this one (note: I haven't used it), it has the most downloads in the repository:

    http://wordpress.org/extend/plugins/wp-mail-smtp/

    You can also do a search for SMTP in the WordPress.org plugin repository.

    Posted 12 years ago on Wednesday September 23, 2009 | Permalink
  9. Same issue.. Is Godaddy hosting known to have this issue?

    Posted 12 years ago on Saturday September 26, 2009 | Permalink
  10. I believe godaddy may be limiting it's sendmail functionality to prevent people from using it to easily send spam. There isn't much you can do in this situation except implement SMTP authentication using one of the available plugins.

    Posted 12 years ago on Sunday September 27, 2009 | Permalink
  11. dixhuit
    Member

    My notifications appear to be working with the exception of the ones sent to my site's associated Google Apps email addresses (any of them). Notification sent my regular Gmail address work fine. I use Media Temple hosting (Linux based).

    What's the suggested fix? Do I need to investigate another WP plugin to get around this?

    Posted 12 years ago on Wednesday March 24, 2010 | Permalink
  12. If your emails are working with the exception of ones sent to Google Apps email addresses than it is a MediaTemple server send mail or Google Apps email specific issue rather than a Gravity Forms or WordPress issue.

    All I can say is try using the WP Mail SMTP plugin and configure it to send email via SMTP.

    http://wordpress.org/extend/plugins/wp-mail-smtp/

    If that doesn't work you may need to work with MediaTemple to determine why email sent isn't arriving at Google Apps.

    Posted 12 years ago on Wednesday March 24, 2010 | Permalink
  13. dixhuit
    Member

    Yep, sure enough, my hosting wasn't configured properly. All fixed now.

    Many thanks.

    Posted 12 years ago on Wednesday April 21, 2010 | Permalink