PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Email Notifications Not Being Dispatched

  1. First of all I want to say gravity forms is the greatest WordPress plugin I've ever used and you guys have done a great job with this!

    I am having a problem though, which is more than likely related to my server but I figured someone might have some idea how I can fix it.

    I have a dedicated server from Host Gator and the PHP mail() function is enabled by default and the email notifications will work on a domain that I haven't made any changes to the MX records on.

    However.. I change my MX records in my DNS (on most of my domains) so I can use Google Accounts to control the my email address, calender, etc. This is just something I've gotten use to doing on all my domains and like the imap email Google offers for free.

    Anyways I'm assuming this is my problem, have you guys ran into this scenario in the past? I noticed in a previous support ticket you recommended an SMTP plugin however I'd rather not install this plugin on every one of my websites if there's an easier solution. Also with hat being said it might be a good feature to include in future releases of Gravity Forms so users can choose how emails are to be sent.

    The strange part is the emails that WordPress generates when theres a new comment on a post are sent and received without a problem, I'm wondering if they are using a different method to send mail via PHP?

    Hope that was clear and I'll look forward to hearing back from someone, Thanks!

    Posted 9 years ago on Thursday April 8, 2010 | Permalink
  2. This is interesting.. I went into the Form Notification Settings and enabled "Email notifications to user". Submitted a a new form and the "user" email address I used received a CC of the submitted form, but the contact email address (admin email) that I have set to receive email notifications did not receive notice of the form being submitted.

    So this tells me the sendmail() function being used in Gravity Forms is in fact working theres just something strange going on here.

    The form can be accessed at: http://www.scriptflipper.com/contact/

    If you fill out the form and submit it you will receive a CC of the contact form at the email address you provide in the form, however contact@scriptflipper.com (admin email) will never receive notice of the form being submitted

    Posted 9 years ago on Thursday April 8, 2010 | Permalink
  3. Could you send us a WordPress admin login for this site so that we can take a look and do some tests? You can do so via our Contact Us form and reference this forum post.

    Gravity Forms uses the built in wp_mail function. It doesn't have it's own mail function, nor does it uses sendmail, although I believe wp_mail does use sendmail.

    Posted 9 years ago on Thursday April 8, 2010 | Permalink
  4. Sure, no problem I will send it over now. Thank you for your help, Carl.

    Posted 9 years ago on Thursday April 8, 2010 | Permalink
  5. Before you send this over, can you make sure the emails aren't ending up in your spam folder? Sometimes Google Apps accounts also has a problem if the send to and the from are the same address.

    So if your Admin Notification is going to admin@domain.com and your Notification is setup so the From address is the same address... it may not like that.

    Posted 9 years ago on Thursday April 8, 2010 | Permalink
  6. Well there you have it. I'm sorry I definitely should have checked the spam folder it's just I never had that problem before. Currently I have the reply address set to the admin email address but I've also tried to set it to the users "email" and as I'm seeing now those messages were also sent to spam.

    I apologize for my ignorance and not checking my spam folder but do you have any tips to keep these messages out of spam ? It seems to only happen on this server..

    Posted 9 years ago on Thursday April 8, 2010 | Permalink
  7. Unfortunately the best way to avoid this is to use an SMTP plugin to force WordPress to send email via SMTP. When sending mail via PHP without using SMTP, depending on your server or host, it can get flagged as spam.

    This is actually an issue anytime you send mail using PHP without using SMTP because it isn't viewed as being from a trusted source.

    But it depends on a variety of factors such as your web host, server configuration, etc. Google tends to be fairly strict with things.

    From the admin side of things if you don't want to use SMTP authentication you can setup a filter to force all emails send from that from address to not going to spam.

    The safest bet in this situation is to use SMTP authentication for an SMTP plugin such as:

    http://wordpress.org/extend/plugins/wp-mail-smtp/

    Gravity Forms uses a WordPress function to send mail, which is why you would need to use an SMTP plugin that tells WordPress to use SMTP.

    Posted 9 years ago on Friday April 9, 2010 | Permalink
  8. ok I'll give this plugin a try. thanks a lot for all your help and information.

    Posted 9 years ago on Friday April 9, 2010 | Permalink
  9. Carl...

    If I am having issues with users who submit the from either 1) not getting the email or 2) it going into their spam folder, will the WP Mail SMTP plugin help that situation? Thanks...

    Jason.

    Posted 9 years ago on Thursday June 17, 2010 | Permalink
  10. Sending email via SMTP plugin can help with this issue as mail sent via authenticated SMTP is considered more reputable by most spam filters.

    A lot of factors determine if an email will get caught in a spam filter including your domain name. If your domain name ends up in one of the various black lists anti-spam providers use, this can also prevent users from receiving emails. Issues with email run deeper than Gravity Forms alone due to the various pieces that come into play (your server configuration, etc.).

    But I would start with using the WP Mail SMTP plugin, just make sure you configure it properly. You may need to contact your web host to get the proper SMTP settings.

    Posted 9 years ago on Thursday June 17, 2010 | Permalink