PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Email Notifications not Working

  1. ok, i scoured the forums and saw a number of tutorials installing plugins for overriding wordpress' default email functionality and pushing through SMTP. I have google apps installed on my clients bluehost account. I followed the tutorials, but still no avail.

    I used both
    WP Mail SMTP and
    Cimy Swift SMTP

    I did recently transfer to a new server my entire wordpress installation through backupBuddy. Not sure if this messes with gravity forms setup, but please advise. I use the form and used the resend to admin email notification and neither generates the email.

    Posted 8 years ago on Tuesday October 2, 2012 | Permalink
  2. Hi greyhavns,

    I too use Bluehost and have been having issues with emails not going to the submitter of the form. The form administrator does receiver email notification.

    I contacted Bluehost who told me it was something to do with proofpoint.com and "They have blacklisted our mailservers IP address."

    Interested to see a workround.

    Posted 8 years ago on Wednesday October 3, 2012 | Permalink
  3. Further to my last email, l also used backupbuddy on my site although only as a backup, not to move site.

    Posted 8 years ago on Wednesday October 3, 2012 | Permalink
  4. Email reliability issues are almost always due to host configuration, or the email providers that handle the email for the recipients. The first thing to do is configure one SMTP plugin and make sure it can deliver the test email reliably. Here are a couple plugins; pick one:

    http://wordpress.org/extend/plugins/configure-smtp/
    http://wordpress.org/extend/plugins/wp-mail-smtp/
    http://wordpress.org/extend/plugins/cimy-swift-smtp/

    If that does not work, please try a different email address for where the notifications are delivered. Preferably one on a different domain (so, instead of the same domain as the website, maybe a Gmail or Yahoo account, or if you are using a Yahoo address, try a Gmail one, or instead of a Google Apps email account, try another email address you own.)

    Gravity Forms hands the mail to the wp_mail() function immediately, so there is not a lot that Gravity Forms can do to effect email delivery. However, because Gravity Forms can change the TO and FROM email addresses, some servers have a problem with the email, since it does not appear to come from where it should be coming.

    Posted 8 years ago on Wednesday October 3, 2012 | Permalink
  5. I would like to echo this. I have also installed configure-smtp, using a gmail smtp server and test email was fine.

    I can even go into entries and do a resend to a to admin and that works fine.

    Only when doing a test run on the form, no notification

    Posted 8 years ago on Friday October 5, 2012 | Permalink
  6. never mind found the problem :) A duh moment

    Posted 8 years ago on Friday October 5, 2012 | Permalink
  7. @cosfrog, what did you find? I'm sure your experience will help someone in the future. Please post here if you can.

    Posted 8 years ago on Saturday October 6, 2012 | Permalink
  8. However, because Gravity Forms can change the TO and FROM email addresses, some servers have a problem with the email, since it does not appear to come from where it should be coming.'

    Can you suggest the settings which would not cause a server problems?

    New user notifications (wordpress) are emailed to addresses but gravity form notify user emails are not being sent out. (

    I have tried all the smtp variants but seem to be trapped between server issue and gravity issue.

    Posted 8 years ago on Sunday October 7, 2012 | Permalink
  9. Colinz, you have a couple things going on. This:

    They have blacklisted our mailservers IP address.

    That's because someone was spamming from the machine where your machine is hosted. There is not a lot you can do about that if the mail is sent from an IP address which is blacklisted. That is a good reason to have your mail sent by and SMTP server.

    I have tried all the smtp variants

    And what happened when you tried them? Let's focus on one. You need to have one configured correctly so the test email arrives, then you can focus on your Gravity Forms notifications.

    New user notifications come from WordPress, usually with the email address wordpress@yourdomain.com - that normally looks OK to the mail server when it's hosted on the same machine. It knows that users from that domain are authorized to use the server. It becomes a problem when the email appears to be sent from the person who submitted the form, which is likely NOT on your domain (could be chrishajer @ gmail . com maybe) - that looks like spam or unauthorized to a lot of webhost mail servers, and it's dropped.

    The answer, in 99.9% of the cases, is to use an external SMTP server to get more reliable email delivery. The server you authenticate to knows who you are, since you just authenticated, and lets you send email without many restrictions. That's why the external SMTP server normally works. When trying to send email from your web host, there is no authentication, and it looks to the MTA on the host like spam, when it starts seeing mail coming FROM user1@wyz.com and TO user2@abc.com when your domain is def.com.

    Posted 8 years ago on Monday October 8, 2012 | Permalink
  10. Chris,

    Thanks very much for your comprehensive suggestions. I'm working through this with the server and trying to establish where the blockage is.

    I'll let you know the result.

    Cheers

    Posted 8 years ago on Tuesday October 9, 2012 | Permalink
  11. @cosfrog what settings did you use for configure-smtp plugin? i used a gmail account and a google apps account and both give me SMTP Error: Could not connect to SMTP host.
    When i used the default settings, it can send through smtp, but gravity forms admin notification sends nothing. Chris is there something we can do to 'reset' gravity forms? I've used it on a number of client projects and I've never had to mess with SMTP.

    Posted 8 years ago on Wednesday October 17, 2012 | Permalink
  12. @greyhavens: "Could not connect to SMTP host" means you have something misconfigured or your website cannot connect to the gmail server. What settings did you use for configuration?

    There is no need to 'reset' Gravity Forms and doing so, if it were possible, would not help this problem. If email notifications are not arriving, it's due to server responsible for delivering the mail, or the server on the other end.

    I just wrote this up today which is a pretty comprehensive description of the problem and solution:
    http://www.gravityhelp.com/forums/topic/bcc-emails-dont-send-on-submit-but-do-send-when-you-use-resend-notifications#post-81644

    Posted 8 years ago on Wednesday October 17, 2012 | Permalink