PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

email notifications not working

  1. Brin
    Member

    Hiya,

    I've just noticed that my email notifications are no longer working - I switched to a DreamHost VPS (although I'm not sure if they stopped working before or after the switch)... any idea what to do? I've checked all the settings and don't remember changing anything since they were last working a few months ago (although I have recently updated gravity forms and switched from a developer license to a personal license)...

    Page in question: http://www.foodfortranslators.com/content-submissions/
    password: submissions

    Thanks,
    Brin

    Posted 6 years ago on Thursday March 21, 2013 | Permalink
  2. David Peralty
    Administrator

    Hi there, can you try out Notifications Troubleshooting steps please? http://www.gravityhelp.com/documentation/page/Troubleshooting_Notifications

    Posted 6 years ago on Thursday March 21, 2013 | Permalink
  3. Brin
    Member

    Hiya, thanks for your reply. I read those. I am running everything up to date (theme, WordPress and all plugins etc), I've never had any conflicts before and am not willing to turn off all my plugins (since I depend on all of these) and don't think this is the problem anyhow, I am also very very reluctant to have to install yet another plugin... I've contacted my web hosts (DreamHost) and am waiting to hear back (although I doub't they'll say much more than "please contact Gravity Forms" - just a guess of course)... I was hoping you'd be able to guess at what the problem is somehow... any idea? Thanks, Brin

    Posted 6 years ago on Thursday March 21, 2013 | Permalink
  4. David Peralty
    Administrator

    As I tried to explain in the troubleshooting steps, Gravity Forms packages up the submitted data, and shoots it over to wp-mail.php (WordPress' sendmail file), and beyond that, Gravity Forms has nothing to do with e-mail. So if there is an issue, and it is not theme or plugin related, then it is server related. There are many security settings that only lets you send e-mails from actual addresses on the server, or anti-spam settings that stop PHP sendmail from working. E-mail on web servers isn't a simple thing.

    Posted 6 years ago on Thursday March 21, 2013 | Permalink
  5. Brin
    Member

    This is the reply from DreamHost: I checked the mail system on your VPS and found no problems. Emails are
    being sent from your website to <submissions@foodfortranslators.com> and
    accepted by Google's servers. Once emails leave DreamHost there's
    nothing more I can do to track them. If you have any specific
    submission-related emails you'd like me to look for, I can check your
    VPS's mail log file; if you want to create an admin user on the VPS that
    user would have access to view that log file.

    Does this help? What would you suggest I need to do in order to fix the problem? Please advise.
    Thanks,
    Brin

    Posted 6 years ago on Thursday March 21, 2013 | Permalink
  6. Brin
    Member

    Aha...I've found all the content submissions in my SPAM folder on gmail... unbelievable! Thanks for your help - my only problem now then is how to stop gmail from marking these as spam...

    Cheers,
    Brin

    Posted 6 years ago on Thursday March 21, 2013 | Permalink
  7. One of my client sites that has been using Gravity Forms for a couple of years and as of 3-22-13 their email functions stopped working all together. I've gone through and checked all of the applicable email addresses, spam folders, etc and nothing is coming in from the submissions.

    In this client's case, they have all of the latest updates applied to their site, none of the email addresses have changes, email communication to those addresses still work properly, no server configuration changes, and no changes outside of the WP site have been made either. They are using a dedicated Gmail address for their server configuration that only is used for email communication from the forms.

    I'm about to call GoDaddy and see if their have been any changes on their end that would have caused the emails not to have been being sent out.

    I will post any additional updates that I can for everyone.

    Posted 6 years ago on Saturday March 23, 2013 | Permalink
  8. Well I'm on the phone with GoDaddy right now. They are indicating that this particular issue is directly related with Gravity Forms. The guy on the phone is telling me that my client's server was recently updated on their end and that is what is causing the email notifications not to be sent out through WordPress / Gravity Forms.

    Any suggestions??? All in all, I probably have 20 client sites that are hosted on GoDaddy and if this is the first one to be affected with their server update then this is going to become a bigger issue down the road for all sites hosted there that run Gravity Forms.

    I would suggest that Gravity Forms look at their email configuration options and help us deal with this issue as a whole.

    Posted 6 years ago on Saturday March 23, 2013 | Permalink
  9. OK.... After looking at lots of settings and configuration files, parameters, and such, I think I have figured out a work around on this for GoDaddy customers / client sites.

    Go to DNS Manager in the GoDaddy control panel for the specified domain name that the site is running under. Look to see if GoDaddy is still your controlling configuration regarding the site email functions. In my case, most of my clients use Google Apps for their email. Remove all DNS entries related to GoDaddy and the mail configuration settings under your CNAME records that still point to secureserver.net.

    Test and continue to have your forms work as normal with emails not being restricted through the GoDaddy configurations.

    Note: If you have more than one domain name / WP setup under your GoDaddy hosting plan, you will need to do this for each domain name.

    Additionally, if you are experiencing a similar issue with another hosting provider, I would recommend looking at this issue with them as well. either migrate your mail to Google Apps or some other email hosting solution and adjust your DNS and MX records accordingly.

    Posted 6 years ago on Saturday March 23, 2013 | Permalink
  10. Thanks for your troubleshooting on this.

    Posted 6 years ago on Sunday March 24, 2013 | Permalink
  11. bluefuze
    Member

    Hi Sayingitfirst,

    I too am with GoDaddy... but when I go to the area you describe, I have no idea what to keep and what to delete. Can you help define that a bit more? I'm not really a tech guy.

    I'm having issues with getting a "notification to user" sent. I'm trying to get a "Refer a Friend" form going, and I'll get a notification as the admin that a form was submitted... however trying to get an email sent to the "Friend" isn't working. Frustrating.

    Thanks
    Doug

    Posted 6 years ago on Friday March 29, 2013 | Permalink
  12. Many hosts will reject email which appears to come from someone they are not supposed to be sending mail from. For example, if your website is example.com, the mail server probably expects all mail to be sent from "someone@example.com". When you try to override this, which Gravity Forms will allow you to do, it looks like relay or spam email, and the server drops it.

    That is why we recommend using an SMTP server. You authenticate to the SMTP server, then that server will deliver any email from you, since it knows who 'you' are. Please see these troubleshooting steps, if you have not already http://www.gravityhelp.com/documentation/page/Troubleshooting_Notifications

    Posted 6 years ago on Monday April 1, 2013 | Permalink