PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Emails arriving styled incorrectly...

  1. Hi,

    I've set up the plugin to email a confirmation to me and to a sender.

    I have set the text to have a blank line in certain sections - it should appear like this:

    Hi Paul,

    Thank you for requesting a quote.

    Your message has been received and I will endeavour to reply within 48 hours.

    Kind regards,
    James Morrison

    Instead it comes through like this:

    Hi Paul,rnrnThank you for requesting a quote.rnrnYour message has been received and I will endeavour to reply within 48 hours.rnrnKind regards,rnJames Morrison

    This is also affecting the onscreen confirmation which a user sees (in the yellow box) so I've had to put everything on one line (not an option for the email).

    How can I sort this out - it looks really unprofessional...

    Thanks

    Posted 9 years ago on Sunday August 30, 2009 | Permalink
  2. James, I will look into this and we will see what could be causing this issue as it isn't a customer wide problem. I may be in touch to gather additional information, in the mean time please post your current versions of PHP, WordPress, and MySQL which you can find in the Settings page of the plugin. Thanks.

    Posted 9 years ago on Sunday August 30, 2009 | Permalink
  3. Hello James,

    Do me a favor and try using HTML <br /> tags where you want carriage returns and let me know if that does the trick. We are still looking into the carriage return issue, but try this in the mean time and let me know.

    Thanks.

    Posted 9 years ago on Sunday August 30, 2009 | Permalink
  4. Also try recreating the notification email. Clear it out, save it and start from scratch and see if it still happens. If so try the solution above using the html tag to force a break. You may need to insert multiple break tags for each carriage return.

    We haven't been able to replicate the issue on our end, so let us know if any of the above resolves it and if not we will continue to try and get things working for you.

    Posted 9 years ago on Monday August 31, 2009 | Permalink
  5. Thanks for the quick reply.

    Changing all the "rn" entries on the email notification to <br />'s has fixed the problem.

    Maybe consider updating the code to insert <br />'s instead of rn's for future releases?

    Consider this solved for now.

    Many thanks!

    FYI:

    PHP Version 5.2.8
    MySQL Version 5.0.67.
    WordPress Version 2.8.4
    Gravity Forms Version 1.0

    Posted 9 years ago on Monday August 31, 2009 | Permalink
  6. Glad to see it worked for you, i'll let the team know and we will come up with a long term solution for this.

    Posted 9 years ago on Monday August 31, 2009 | Permalink

This topic has been resolved and has been closed to new replies.