PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Enhanced User Interface (Chosen) doesn't work for me

  1. Hi,
    The Enhanced User Interface doesn't work for me and I don't manage to know why...

    It doesn't seem to be a script conflict, but I'm not sure.

    This is an example of the infamous issue (on the test site):
    http://forumeteoclimat.cooperanet.fr/volet-professionnel/colloque-international/inscription-au-colloque-international/

    As you can see, below "Méthode de paiement", the dropdown can't use the Enhancer User Interface. And I don't know how to solve this issue.

    Any help would be greatly appreciated!

    Cédric

    Posted 7 years ago on Sunday January 13, 2013 | Permalink
  2. I don't see the chzn class in the source of the page, and I don't see the chosen.js script being included. Do you have the "Enable enhanced interface" check box checked right now for this form?

    Posted 7 years ago on Sunday January 13, 2013 | Permalink
  3. Sorry, I needed to disable Enhanced Interface in order to test the form this afternoon.

    I just enabled Enhanced Interface, you can check again: http://forumeteoclimat.cooperanet.fr/volet-professionnel/colloque-international/inscription-au-colloque-international/

    Posted 7 years ago on Sunday January 13, 2013 | Permalink
  4. You have a couple things going on. What theme was used as a base for this custom theme?

    1. Your theme is including jQuery 1.7.2. WordPress 3.5 should be including jQuery 1.8.3 and that's what Gravity Forms relies on. Please let WordPress do its job and enqueue the proper version of jQuery.

    2. Your theme is including a bunch of extra, incorrect markup in the gravityform shortcode output. If you check the source of the page, you will find near the gform_body, gform_footer and gform_wrapper, all sorts of closing < p > and < br > tags. That is being done by something in your installation, normally the inclusion of the [raw] shortcode. You can read more about it here. http://www.gravityhelp.com/forums/tags/raw

    The quick fix is, in the editor where you embedded the form, surround the [gravityforms] shortcode with [raw] [/raw] tags. That normally works around the problem of the extra markup being added by the theme (or sometimes a plugin.)

    Check your form in the form preview. If the enhanced interface works there, you can be sure it is a theme or plugin conflict which is causing the problem. You can find out exactly where the problem is coming from by using these instructions to test for theme and plugin conflicts http://rkt.gs/testing

    Posted 7 years ago on Sunday January 13, 2013 | Permalink
  5. Hi,
    Thank you very much for your reply.

    I'm going to follow your instructions and I will let you know.

    Thanks again for the awesome support!

    FYI: I use the Reverie Wordpress Framework: http://themefortress.com/reverie/

    Posted 7 years ago on Monday January 14, 2013 | Permalink