PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Entries not Exporting

  1. dfrayne
    Member

    About a week ago I was able to successfully export/download the entries CSV file, but today the timer wheel keeps spinning and I get no file. I am using GF 1.4.5 and have tried it with Safari and Firefox. I am able to download the entries CSV from another site on the same server. I wonder if it has to do with the size of the CSV file being generated? There's about 17,000 entries with about 28 fields in the form. How long should I wait for the file? Or might it be another issue?

    Posted 9 years ago on Monday March 28, 2011 | Permalink
  2. This shouldn't be a problem, I would suggest waiting. If it doesn't work, it could be a performance issue on your web server. The export functionality works the same way as the WordPress export post/pages functionality. So it isn't doing anything out of the ordinary. It could be because of the large number of fields combined with the number of entries. Are you on a shared host? It could be a performance issue.

    Posted 9 years ago on Monday March 28, 2011 | Permalink
  3. dfrayne
    Member

    It's a dedicated server (liquidweb - 2133 MHz Xeon, 8 Gig ram). I will keep waiting and let you know what happens. Does GF create a subdirectory in the Uploads directory for the entries export files? I do not see one. Thanks.

    Posted 9 years ago on Monday March 28, 2011 | Permalink
  4. The export file is streamed directly to the browser, a file isn't created and stored on the server. This is how the WordPress post exporter also works. Try updating to the new Gravity Forms v1.5 release, the export functionality was made more efficient in the new release. That could solve your problem as it is more efficient.

    Posted 9 years ago on Monday March 28, 2011 | Permalink
  5. dfrayne
    Member

    Thanks Carl. It is still spinning after about 45 mins. I was thinking about updating to 1.5, and I know it's usually a good idea, but I am a bit nervous as we are in the middle of a contest and I do not want to mess things up. On the other hand, if I cannot download the entries, that might be my only option for retrieving the entries - or is there another way?

    Posted 9 years ago on Monday March 28, 2011 | Permalink
  6. @dfrayne I would suggest updating and then trying the export. The update shouldn't impact your entries. If you have an issue/error when updating just get in touch.

    Posted 9 years ago on Monday March 28, 2011 | Permalink
  7. dfrayne
    Member

    The update seems like it went fine, but now when I export entries (Import/Export > Export Entries > Select a Form, Select all Fields > Download Export File), I just get a csv file with a single field containing the total number of entries.

    Posted 9 years ago on Monday March 28, 2011 | Permalink
  8. Make sure you are selecting all the fields when selecting what you want to export. If you continue having problems, if you send us a WordPress admin login via our Contact Us form we can take a look. We may also need an FTP login but we can start with WordPress access. Reference this forum post when contacting us.

    Posted 9 years ago on Monday March 28, 2011 | Permalink
  9. dfrayne
    Member

    Thanks Carl. I just sent it via Contact Us.

    Posted 9 years ago on Monday March 28, 2011 | Permalink
  10. The first thing I notice is you are encountering a MOD_SECURITY problem. MOD_SECURITY is a server firewall on your web host. They will need to adjust some settings, when this occurs you need to contact your host and explain the issue and they should be able to whitelist the Gravity Forms scripts.

    Your MOD_SECURITY settings are blocking the AJAX request because it thinks it's a malicious attack. See this forum post, it outlines the fix and you may need to get in touch with your web host to implement it:

    http://www.gravityhelp.com/forums/topic/forms-not-updating-after-being-saved#post-10305

    I noticed this when I tried to make an edit to your form title, it wouldn't save. This is probably the source of your export issue also.

    Posted 9 years ago on Monday March 28, 2011 | Permalink