PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Entry count shows zero after upgrade

  1. steve.barnett

    After upgrading from to, the Entry count for all forms shows zero in the Dashboard and on the Form pages. Entries aren't displayed for any of the forms. The entries are still in the database, though.
    Any idea as to why this could be happening, and how I can fix it?

    Possibly related is that calls to RGFormsModel::get_leads() return empty (after upgrade), even on straightforward calls such as RGFormsModel::get_leads(1) .
    Other functions in the same class work fine, e.g. RGFormsModel::get_form_meta, RGFormsModel::get_lead, RGFormsModel::get_field_value_long.


    Posted 10 years ago on Tuesday February 14, 2012 | Permalink
  2. Hi, Steve,

    This could be a database permission issue. From v1.5 to 1.6 a new database field was added and we have had a few users who did not have the appropriate database permissions so the new field could not be generated while updating, causing the database queries to fail and show zero entries even though the data is still there.

    Make sure you have the ability to ALTER your Gravity Forms' database tables. Then you can try the following:

    1. If you have uninstalled v1.6.2x, reinstall it.
    2. Turn on debug mode so errors are displayed (wp_debug in wp-config.php).
    3. Force the database update by going to the settings page (Forms->Settings) and adding "&setup" to the query string, so that the page looks something like "...wp-admin/admin.php?page=gf_settings&setup"

    If there are any errors as far as updating the database you should see them. Some have had simply forcing the database update create the database field and fix their issue.

    If there are no errors and this doesn't fix your issue, another thing to check would be your php memory; it could need to be increased since there are a lot of new features in 1.6.2x.

    Let me know if you have questions.

    Posted 10 years ago on Thursday February 16, 2012 | Permalink
  3. steve.barnett

    Hi Dana.

    Thanks for your reply.

    Adding &setup to the URL on Forms > Settings gives a number of "Table already exists" errors of the form:
    WordPress database error: [Table 'wp_rg_form' already exists]
    for the GF tables.

    Setting WP_DEBUG to true gives me the following error:
    WordPress database error: [Unknown column 'status' in 'where clause']
    SELECT form_id, count(id) as lead_count FROM wp_rg_lead l WHERE status='active' GROUP BY form_id
    The status column is missing from rg_lead: it seems the upgrade doesn't add that column to the table.
    With a fresh install of the status column is present in rg_lead.

    I could manually add the status column to rg_lead and set all rows to "active", but is there a more elegant solution?


    Posted 10 years ago on Friday February 17, 2012 | Permalink
  4. Adding the "&setup" to the querystring should have created the field; this worked for other users, and it shouldn't attempt to create a table that already exists. Were those error, warning, or notice messages? It is okay if they were just notices or warnings.

    Manually creating the field should not be necessary. What state are you in right now? You said a fresh install of created the field.

    The best solution would be remove Gravity Forms (NOT UNINSTALL) by following the steps below.

    The steps below will only remove the gravityforms files so you can install the latest version again. This does NOT touch your data.
    1. Download and save the latest version of Gravity Forms from the Plugin Downloads page (
    2. Select the "Deactivate" option for the Gravity Forms plugin
    3. Select the "Delete" option for the plugin
    4. Answer yes when prompted to delete the files. If you are uncomfortable with this you may make a backup of the folder (...wp-content\plugins\gravityforms). This step deletes the folder gravityforms and the files inside.
    5. Select the option to "Add New" plugin
    6. Select "Upload"
    7. Browse to the location where you saved the file and select it
    8. Click "Install Now". You should see the message "Plugin installed successfully." This step recreates the folder gravityforms and the files inside.
    9. Click "Activate Plugin"

    This should be a completely fresh install of the files and any database updates needed (new field created) should be done.

    Posted 10 years ago on Friday February 17, 2012 | Permalink
  5. steve.barnett

    I confirm that the &setup in the query string didn't work for me, but that a fresh install of on a different WP install, worked fine (as one would expect).

    I ended up adding the column manually in phpmyadmin, before I'd seen your response, since it was a quick job to do.

    Thank you for the help!

    Posted 10 years ago on Monday February 20, 2012 | Permalink

This topic has been resolved and has been closed to new replies.