PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

error: on Submit re-directs to another site

  1. Hi - have unintsalled and re-installed a few times and no luck. When I click submit on my form it redirects to another website of mines' contact page. At no point had I set it up to do this.

    Please advises where I can see the action of the submit button as I need this to stop. or why it would be doing this?

    thanks

    craig

    Posted 6 years ago on Monday April 15, 2013 | Permalink
  2. Richard Vav
    Administrator

    Hi Craig,

    The first place to check is on the confirmation tab of the form settings which you can access by editing the form and selecting 'Form Settings' and see if 'Redirect' is selected with a url entered.

    http://www.gravityhelp.com/documentation/page/Form_Settings

    If that is not set to redirect to a url then the next place to look is in your functions.php file for something like this

    add_filter("gform_confirmation", "custom_confirmation", 10, 4);

    if you find it copy it including the function below so we can take a look at it and see exactly what it is doing before we advice the next move.

    Regards,
    Richard
    --
    Just another member of the community helping out where I can

    Posted 6 years ago on Monday April 15, 2013 | Permalink
  3. Hi Richard,

    The confirmation tab is set to text.

    I have looked in my functions.php file and there is no function regarding gform.

    The website is: http://www.i-innovate.co.za

    this is all that is there:

    <?php
    add_action( 'after_setup_theme', 'et_setup_theme' );
    if ( ! function_exists( 'et_setup_theme' ) ){
    function et_setup_theme(){
    global $themename, $shortname;
    $themename = "Webly";
    $shortname = "Webly";

    require_once(TEMPLATEPATH . '/epanel/custom_functions.php');

    require_once(TEMPLATEPATH . '/includes/functions/comments.php');

    require_once(TEMPLATEPATH . '/includes/functions/sidebars.php');

    load_theme_textdomain('Webly',get_template_directory().'/lang');

    require_once(TEMPLATEPATH . '/epanel/options_webly.php');

    require_once(TEMPLATEPATH . '/epanel/core_functions.php');

    require_once(TEMPLATEPATH . '/epanel/post_thumbnails_webly.php');

    include(TEMPLATEPATH . '/includes/widgets.php');

    require_once(TEMPLATEPATH . '/includes/additional_functions.php');
    }
    }

    add_action('wp_head','et_portfoliopt_additional_styles',100);
    function et_portfoliopt_additional_styles(){ ?>
    <style type="text/css">
    #et_pt_portfolio_gallery { margin-left: -10px; }
    .et_pt_portfolio_item { margin-left: 11px; }
    .et_portfolio_small { margin-left: 0px !important; }
    .et_portfolio_small .et_pt_portfolio_item { margin-left: 26px !important; }
    .et_portfolio_large { margin-left: -12px !important; }
    .et_portfolio_large .et_pt_portfolio_item { margin-left: 13px !important; }
    </style>
    <?php }

    function register_main_menus() {
    register_nav_menus(
    array(
    'primary-menu' => __( 'Primary Menu' ),
    'footer-menu' => __( 'Footer Menu' )
    )
    );
    }
    if (function_exists('register_nav_menus')) add_action( 'init', 'register_main_menus' );

    // add Home link to the custom menu WP-Admin page
    function et_add_home_link( $args ) {
    $args['show_home'] = true;
    return $args;
    }
    add_filter( 'wp_page_menu_args', 'et_add_home_link' );

    add_action('wp_head','et_add_meta_javascript');
    function et_add_meta_javascript(){
    global $shortname;
    echo '<!-- used in scripts -->';
    echo '<meta name="et_featured_auto_speed" content="'.get_option($shortname.'_slider_autospeed').'" />';
    echo '<meta name="et_featured_slider_effect" content="'.get_option($shortname.'_slider_effect').'" />';

    $disable_toptier = get_option($shortname.'_disable_toptier') == 'on' ? 1 : 0;
    echo '<meta name="et_disable_toptier" content="'.$disable_toptier.'" />';

    $featured_slider_auto = get_option($shortname.'_slider_auto') == 'on' ? 1 : 0;
    echo '<meta name="et_featured_slider_auto" content="'.$featured_slider_auto.'" />';

    $featured_slider_pause = get_option($shortname.'_pause_hover') == 'on' ? 1 : 0;
    echo '<meta name="et_featured_slider_pause" content="'.$featured_slider_pause.'" />';
    }

    if ( ! function_exists( 'et_list_pings' ) ){
    function et_list_pings($comment, $args, $depth) {
    $GLOBALS['comment'] = $comment; ?>
    <li id="comment-<?php comment_ID(); ?>"><?php comment_author_link(); ?> - <?php comment_excerpt(); ?>
    <?php }
    } ?>

    Posted 6 years ago on Monday April 15, 2013 | Permalink
  4. Richard Vav
    Administrator

    Craig I have I had a quick look at your site but the form that is displayed on your contact page is not a gravity form, inspecting the code just above that form I can see the gravity form wrapper containing the form description but there aren't any gravity forms fields contained in it, the gravity form submit button is also missing.

    Posted 6 years ago on Monday April 15, 2013 | Permalink
  5. Richard Vav
    Administrator

    Also if you go into the WordPress admin > 'general settings' what are your 'WordPress Address (URL)' and 'Site Address (URL)'

    And do you have any plugins that could be messing with permalinks etc, you should try testing for a plugin/theme conflict by following the advice here http://rkt.gs/testing

    Posted 6 years ago on Monday April 15, 2013 | Permalink
  6. Hi Richard, Apologies - I removed the form as the site is live. I have replaced the form.

    I have also changed theme and deactivated all plug ins and it does the same thing.

    I also then tried to make the confirmation tab set to a page and not a message but it doesn't work either so something in the hard code is giving the re-direct automatically.

    This is so strange as I have used gravity forms on many of my sites and never had this issue. Please advise the next step

    Posted 6 years ago on Tuesday April 16, 2013 | Permalink
  7. Hi Richard, in the actual code on the live site it seems to have the following action on the form:

    form id="gform_1" action="http://bantergraphics.com/contact-us/" enctype="multipart/form-data" method="post"

    And that tis the website it re-directs to - so where would I find this to change it and to what?

    Posted 6 years ago on Tuesday April 16, 2013 | Permalink
  8. Richard Vav
    Administrator

    If you go into the WordPress admin > 'general settings' what are your 'WordPress Address (URL)' and 'Site Address (URL)'

    Posted 6 years ago on Tuesday April 16, 2013 | Permalink
  9. WordPress Address (URL): http://i-innovate.co.za
    Site Address (URL): http://i-innovate.co.za

    Posted 6 years ago on Tuesday April 16, 2013 | Permalink
  10. I have taken the form off the live site and can be viewed here http://i-innovate.co.za/contact-2/

    Posted 6 years ago on Tuesday April 16, 2013 | Permalink
  11. Hi Richard,

    have you managed to have a look again since the i re-loaded the form and provided more info? I also tried to target the specific form with the gform_confirmation string but it never worked either.

    thanks Craig

    Posted 6 years ago on Thursday April 18, 2013 | Permalink
  12. David Peralty
    Administrator

    Can you go to Settings -> Permalinks and change it to default and save it and then back to whatever you have it set to and save it, and see if that helps at all? Gravity Forms is getting the wrong submission URL from somewhere. Usually, like Richard said, it is in your Settings -> General.

    Posted 6 years ago on Thursday April 18, 2013 | Permalink
  13. Richard Vav
    Administrator

    Sorry Craig,

    I didn't get the email notification about your new post.

    Posted 6 years ago on Thursday April 18, 2013 | Permalink
  14. castledesign
    Member

    Hi Guys! I was happy to see this post as I am having the same issue and it is driving me NUTS!

    I have made a new site with donation gravity form here: https://missioninactionnyota.com/donate-to-mia-2/

    The confirmation page I have it set to is another page in the site. http://missioninactionnyota.com/thank-you-for-your-donation/

    but no matter what I do (i have deactivated plugins, changed permalinks, changed themes, exported, imported, re built etc) it keep submitting to this page when the submit button is pressed! https://missioninaction.com.au/kenya/donate/ (this is another site I have built for the same charity)

    I can see when I 'inspect element' that this url is in the top of the form (see image here https://missioninactionnyota.com/wp-content/uploads/2013/04/Screen-Shot-2013-04-28-at-2.02.40-PM.png) but I have no idea where is is pulling this URL from and how to change it?

    Im hoping someone can help me! the site is live and im desperate to tell the world as we need to start getting donations but I cant until the site is fixed.

    Thank you in advance!!! :)

    Sarah

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  15. Richard Vav
    Administrator

    Hi Sarah,

    How did you create the new site, was it a fresh install or did you backup the other site including database and then restore it to this new domain then customise it from there, if so it's likely the the other domain is still recorded in the database.

    Regards,
    Richard

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  16. castledesign
    Member

    Hey Richard!

    So nice to hear from you so quickly! Thank you!

    It was a COMPLETE new install.. I did however import the donate form from the other site over to this one.. but since then I have totally rebuilt form from scratch and it still does the same?

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  17. Richard Vav
    Administrator

    If you create a new form from scratch with just one field does the same thing happen?

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  18. castledesign
    Member

    I have only tried to create a new form with the credit card option and the same thing happens then..

    the other forms on the site work AOK.. see example here: http://missioninactionnyota.com/sponsor-a-child/

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  19. Richard Vav
    Administrator

    Something is screwing around with the form markup, this is what you have

    <div id="gform_wrapper_1">
    <form id="gform_1" action="https://missioninaction.com.au/kenya/donate/" enctype="multipart/form-data" method="post">
    <div>Use this form to make an online donation to Mission in Action.Make a choice of where you would like the money to go by choosing from the ‘campaign’ drop down box below.</div>
    <div></div>
    <div>
                    <div class='gf_browser_chrome gform_wrapper' id='gform_wrapper_6' style='display:none'><form method='post' enctype='multipart/form-data'  id='gform_6'  action='/donate-to-mia-2/'>
                            <div class='gform_body'>

    and this is what it should be

    <div class='gf_browser_chrome gform_wrapper' id='gform_wrapper_6' style='display:none'><form method='post' enctype='multipart/form-data'  id='gform_6'  action='/donate-to-mia-2/'>
                            <div class='gform_heading'>
                                <span class='gform_description'>Use this form to make an online donation to Mission in Action.Make a choice of where you would like the money to go by choosing from the 'campaign' drop down box below.</span>
                            </div>
                            <div class='gform_body'>

    I know you said you tried this but can you try disabling all other plugins so only the Gravity Forms plugin is active and then see if that makes any difference to the markup I have shown above.

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  20. castledesign
    Member

    Should I also deactivate the gravity forms payment plugins that I need to use for this form? (Gravity Forms eWAY + eWAY Payment Gateway) ?

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  21. Richard Vav
    Administrator

    Yes please temporarily deactivate all plugins other than the main gravity forms plugin

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  22. castledesign
    Member

    Thank you,

    I just deactivated everything except the main plug in and tried it (you can just hit submit form as non of the entries are set to required) and it still went to the same page! arghhhh!!

    I'll leave it like this so you can see also

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  23. Richard Vav
    Administrator

    OK, how are you embedding the form on the page, can you post the embed code you used on that page.

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  24. castledesign
    Member

    I use the 'insert a form' option and this is the code thats on there..

    [gravityform id="6" name="Online Donation for Mission in Action Nyota via Credit Card" title="false" description="false"]

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  25. Richard Vav
    Administrator

    Does the same thing happen when you preview the form from admin?

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  26. castledesign
    Member

    Just tried it and it went to the correct page when i previewed form from admin!

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  27. Richard Vav
    Administrator

    If it works when previewed from admin but doesn't work when embedded on a page it would usually suggest there is a plugin or theme conflict. You said earlier that forms on other pages don't experience this issue so it would suggest that there is something different with the theme or plugins on this particular page for it to be the only one affected.

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  28. castledesign
    Member

    That fixed it!! It is SO WEIRD!!

    I moved the form to a page of its own and now it is working?!

    I can't thank you enough for your persistence in helping me with this. I can now go live and tell the world of the new site tonight. You are wonderful! Thank you so so much

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  29. Richard Vav
    Administrator

    You're welcome, just glad you got it working again.

    Posted 6 years ago on Monday April 29, 2013 | Permalink

This topic has been resolved and has been closed to new replies.