PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Error on upgrade

  1. Tony Jansen
    Member

    After upgrading to 1.1.3 i get the following error when trying to activate: "parse error: syntax error, unexpected T_PUBLIC in C:\Users\Toon\www\robdenijs.lokaal\wp-content\plugins\gravityforms\gravityforms.php on line 2270".

    Tinkering leads to the conclusion that this error started to appear from version 1.1 and on. Both 1. 0 and 1.0.1 do not have this problem.

    I'm at the custom-forms part of my project and would very much like to use Gravity forms.

    Posted 12 years ago on Sunday October 4, 2009 | Permalink
  2. Hey Tony, can you verify you are running PHP5 on that site? Typically errors such as this are caused by site running PHP4 instead of PHP5. Let me know, thanks!

    Posted 12 years ago on Sunday October 4, 2009 | Permalink
  3. Tony Jansen
    Member

    Hi Carl,

    The server is running:
    • PHP 5.3.0
    • Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 mod_perl/2.0.4 Perl/v5.10.0
    • MySQL 5.1.37

    I noticed in the forum that someone else had this error too: http://forum.gravityhelp.com/topic/instalation-error.
    And like i said before, this error appears from version 1.1 and up, it's not showing at older versions.

    P.S. Ran the compatibility checker plugin too btw, which gives: "Congratulations! Gravity Forms is supported! Get your copy of Gravity Forms here"

    Posted 12 years ago on Sunday October 4, 2009 | Permalink
  4. Tony Jansen
    Member

    One more thing, i tried suppressing the error by setting the error reporting values in php.ini to the same as on my production machine, but since this is a fatal error, there's no way around it.

    Posted 12 years ago on Sunday October 4, 2009 | Permalink
  5. Tony Jansen
    Member

    Problem solved.

    Posted 12 years ago on Sunday October 4, 2009 | Permalink
  6. The issue was some PHP open tags that were not using the longform <?PHP but instead were using simply <?, some web servers cannot handle this depending on their configuration. We will take care of these in the next release.

    Posted 12 years ago on Sunday October 4, 2009 | Permalink