PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Error when upgrading to 1.6.5

  1. I received the following error on the most very recent plugin update:

    Current database user does not have necessary permissions to modify (ALTER) tables.

    Any idea what this means? All other updates for past 6 months have upgraded well. Thanks!

    Posted 9 years ago on Thursday July 26, 2012 | Permalink
  2. David Peralty

    This means that the permissions on your server for the user tied to your WordPress account has been changed, and the ability to Alter tables has been removed. If you use CPANEL, you should check your database user and make sure it can alter tables on the database you have WordPress installed on. You might want to contact your host about this issue.

    Posted 9 years ago on Thursday July 26, 2012 | Permalink
  3. Is there something in the latest update that triggers this? Haven't run into this before with GF updates.

    Posted 9 years ago on Thursday July 26, 2012 | Permalink
  4. David Peralty

    Nothing in Gravity Forms could have changed your database permissions.

    Posted 9 years ago on Thursday July 26, 2012 | Permalink
  5. Hi David - I just got the exact same error when upgrading. DB user has full privileges (as set through Cpanel) and always has done. Nothing has changed with regard to the DB user since the site was established. A cursory look around the site seems to suggest everything is working OK though it would be good to have it confirmed that that error won't cause any unforeseen glitches down the line

    Posted 9 years ago on Thursday July 26, 2012 | Permalink
  6. straitline
    Member

    I am randomly receiving this error on some sites but not others when upgrading to 1.6.5. The sites in question are on the same server with the same set of permissions for the database user which haven't posed any problems in the past.

    Posted 9 years ago on Thursday July 26, 2012 | Permalink
  7. This message is being displayed due to a small issue in Gravity Forms when attempting to detect if the current user has the proper database permissions. This should not cause any other problems down the line. The next release will have a fix for this problem, but if you would like the fix sooner, email me to alex@rocketgenius.com

    Posted 9 years ago on Thursday July 26, 2012 | Permalink
  8. Anonymous
    Unregistered

    I'm also seeing this issue, the same as previous users have mentioned. I'm using it on Multisite, and am also seeing errors above the dashboard on some sites within the Network:

    Warning: Cannot modify header information - headers already sent by (output started at /home/siteroot/public_html/wp-content/plugins/gravityforms/gravityforms.php:264) in /home/fiddlers/public_html/wp-includes/option.php on line 563
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/siteroot/public_html/wp-content/plugins/gravityforms/gravityforms.php:264) in /home/siteroot/public_html/wp-includes/option.php on line 564

    But it does go away when clicking through to other things, along with the permissions error described by others.

    Posted 9 years ago on Thursday July 26, 2012 | Permalink
  9. @Tevya As Alex mentioned above, the permission error is benign and won't cause an issue with your site. It was an issue that only appeared if a users MySQL database server was configured a specific way. It won't cause any issues and will only appear during the upgrade routine.

    As for the Warnings you are getting, that is odd as i'm unable to recreate it locally. That occurs when there is extra whitespace in a file. If you continue to see that Warning message I would suggest re-downloading the latest version of Gravity Forms from the Downloads page and replace your existing plugins files with the latest version. It's possible files were manipulated when your WordPress site executed the automatic update.

    We have updated the Gravity Forms build to v1.6.5.1 and users who update to v1.6.5 going forward will actually be installing v1.6.5.1. This update resolves the ALTER permission message that is seen by some users. The v1.6.5.1 release is also what is now available on the Downloads page.

    Any users that are encountering this issue... read this entire reply. You'll only see that permission related message when upgrading, so it isn't critical to update to v1.6.5.1 simply because you saw the ALTER permission error.

    HOWEVER if you get the "Current database user does not have necessary permissions to modify (ALTER) tables." error message when upgrading to v1.6.5.1... then you do have a database user permissions issue that you will need to resolve.

    Posted 9 years ago on Thursday July 26, 2012 | Permalink

This topic has been resolved and has been closed to new replies.