PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Export Feature Not Working

  1. andria

    When I go to "export for entries" and select the employment form I would like to export...I then select "all" not enter in a date range and click "download export file" and nothing happens.

    I've tried to find my file on my server and have tried exporting on a mac and!!!

    thank you!

    Posted 12 years ago on Monday December 21, 2009 | Permalink
  2. Hello Andria, what browser are you using?

    One thing to try real quick is to try using a different browser (ex. if you are using IE try using FireFox, if you are using FireFox try using Chrome or Safari). We don't have reports of issues, but javascript is used for this so it could be related.

    When you click the download link your browser should begin downloading the file. It isn't stored on the server.

    Let me know, but thats the first step in determining the problem with this issue.

    Posted 12 years ago on Monday December 21, 2009 | Permalink
  3. maratino

    same issue for me; setup GF 1.3.4 / WP 2.8.6; export is not working on mac (firefox, chrome and safari). IE on Win brings a js error in tw-sack.js
    upgraded to 1.3.7 - no luck!

    Posted 12 years ago on Tuesday December 22, 2009 | Permalink
  4. Can you use the Contact Us form on this site to send us a WordPress login for this site so we can try the export and see if we can debug the issue? It's much easier to debug an issue that you can see happening as we aren't able to replicate it on our end. Let me know.

    Posted 12 years ago on Tuesday December 22, 2009 | Permalink
  5. maratino

    done -please check your inbox

    Posted 12 years ago on Tuesday December 22, 2009 | Permalink
  6. maratino

    upgrading to wp 2.9 did not change that:

    Meldung: ')' erwartet
    Zeile: 1
    Zeichen: 2276
    Code: 0

    Posted 12 years ago on Tuesday December 22, 2009 | Permalink
  7. Double check to make sure that your uploads folder is writeable. It will need permissions set to 755 along with it's subfolders.

    Gravity Forms writes to this folder when it creates an export or uses the file upload field.

    It creates the following folder:


    If this folder does not exist, chances are it is a permissions issue preventing Gravity Forms from creating it.

    Posted 12 years ago on Tuesday December 22, 2009 | Permalink
  8. maratino

    it did work after i changed permissions of wp-content to "777" (was 755). an error warning would be helpful. thanks for your help. GF is a fine plugin!

    Posted 12 years ago on Tuesday December 22, 2009 | Permalink
  9. Good to hear! Glad that solved the problem.

    Posted 12 years ago on Tuesday December 22, 2009 | Permalink
  10. I am having the same issue in 2.9 with both IE and Firefox.
    I already sent a login to the site via contact form that Carl has used for the file upload fail issue: (

    PHP Version 5.1.6
    MySQL Version 5.0.45
    WordPress Version 2.9
    Gravity Forms Version 1.3.8

    Out of curiosity, is anyone else who experiences this issue on Plesk based VPS system?

    Posted 12 years ago on Monday January 4, 2010 | Permalink
  11. Nobody else has reported this issue, and when it is reported it is always an issue with file permissions. From your previous support issues it seems Plesk isn't playing nicely with how it is handling file permissions.

    I think it might have something to do with user accounts also, what user sets the file permission. It is setting the permission in such a way that it isn't actually letting anything else utilize it, despite the fact it appears the permissions should be correct.

    Posted 12 years ago on Monday January 4, 2010 | Permalink
  12. Polle

    Still experiencing the above mentioned problem here, after trying all the solutions in this topic. Can somebody help me with this one? I really need the export...

    Posted 12 years ago on Wednesday February 24, 2010 | Permalink
  13. I'm also having issues with client unable to export data from his site, and I am also unable to export using either IE or Firefox. Permissions are set to 777 on the wp-content/uploads/gravity_forms folder and its subfolders so that's OK.

    On your first attempt to download using IE, the browser pops up the yellow warning bar, asking if you want to allow download. When you click yes, nothing happens, you are returned to the Gravity Forms download UI screen.

    On your second attempt to click to download, you get an Internet Explorer error box with "unable to download download.php from Unable to open this Internet site. The requested site is either unavailable or cannot be found."

    However, when you look in the wp-content/uploads/gravity_forms folder you do find that it created a CSV on your server in that folder. This doesn't help my client, who is expecting to be able to save the CSV on his local PC.

    With Firefox, when you click Export button, the export animated icon runs at screen bottom and it stays on the export screen, no other messages or popups, and a copy of the CSV is created in the uploads/gravity_forms folder. No opportunity to save the file to your local PC is presented.

    From the sound of the "unable to download download.php" error in IE, this might be an issue where code can't find a path? We have WordPress installed in a folder off the root, and this site is hosted on GoDaddy. We already experienced an issue with GF unable to find .js files on GoDaddy hosting earlier that prevented conditional form fields from working (which was fixed in the last upgrade of Gravity Forms thanks to Carl) so this may be a similar situation with the export code unable to find a path?

    I've spent some time debugging this, no luck yet.

    Posted 12 years ago on Saturday February 27, 2010 | Permalink
  14. Very good point on the GoDaddy issue. We will look into this and see if it might be a related issue. It could explain why we are unable to reproduce it and only a select few people are impacted by it.

    Posted 12 years ago on Monday March 1, 2010 | Permalink
  15. phatoz

    I too am having the same experience that AtlantaWebDesi is having. I am not on GoDaddy. Folder permissions are set correctly and the .csv files is written to the server but will not download via the browser. Have tested in Firefox and IE and Chrome.

    PHP Version 5.2.11
    MySQL Version 5.0.89
    WordPress Version 2.9.2
    Gravity Forms Version 1.3.10

    Posted 12 years ago on Thursday March 4, 2010 | Permalink
  16. @phatoz In order to look into this issue we would need access to your site as we are unable to reproduce it on our end. If you can give us access, use the Contact Us form to send us a WordPress admin login AND FTP information and we can debug what is going on and resolve the issue.

    Posted 12 years ago on Thursday March 4, 2010 | Permalink
  17. phatoz

    Hi Carl,
    I have sent you the requested information. Thank you.

    Posted 12 years ago on Saturday March 6, 2010 | Permalink
  18. @phatoz: The issue in your case is a conflict with the GZIP Output plugin. It isn't really a conflict, the GZIP Output plugin is trying to manipulate the output of the export file which is causing the problem. Both plugins are doing what they are designed to do, however the GZIP plugin is trying to do things on the backend when it should be limited it's operation to the frontend.

    Posted 12 years ago on Wednesday March 10, 2010 | Permalink
  19. bayside

    Had the same issue as others on a Plesk VPS.

    Issue resolved by deleting the wp-content/uploads/gravity_forms folder and then remaking folders for

    wp-content/uploads/gravity_forms (set permissions 777)


    wp-content/uploads/gravity_forms/id (where id is the numeric id of the form you are trying to export, also set permissions to 777)

    Posted 12 years ago on Sunday March 14, 2010 | Permalink
  20. Yes, the issue appears to have to do with the user account that creates the folders. For some reason when the PHP creates the folders and sets the permissions, it then can't use them. If a user with higher access rights creates the folder and sets the permission... it works.

    There isn't much we can do about this on our end, this is a Plesk VPS issue or possibly a configuration issue with how PHP runs on the server.

    Glad to see you figured it out and got it working. We are going to be changing the export process so it just exports to uploads/gravity_forms instead of a subfolder so it will be one less step when this issue occurs.

    Posted 12 years ago on Monday March 15, 2010 | Permalink
  21. I had the export problem too (in my case, the export never started. That chasing circle just kept going and going. But I was able to fix it! Yea!

    I've noticed that I had problems setting up new Wordpress blogs for clients. New installs always had problems initially uploading. I CHMOD'd til I was blue! Then, finally found an idea on some forum someplace that suggested deleting the directory in my FTP program, the make a new directory with the same name and CHMOD the new directory.

    I did that with wp-content/uploads/gravity_forms folder and son of a gun it worked!

    Posted 12 years ago on Thursday March 18, 2010 | Permalink
  22. Well, I spoke too soon. A file named export.csv was downloaded - but it's empty! Now, I am stuck again.

    Posted 12 years ago on Thursday March 18, 2010 | Permalink
  23. You are experiencing a hosting related file permissions problem. The user account that the PHP is running under is having problems creating folders/files despite the fact the CHMOD permissions appear to be correct.

    You may want to contact your host to see if they have any ideas on what could cause a PHP app not to be able to write to a folder despite the fact you have set the folder permissions to the correct level.

    Posted 12 years ago on Thursday March 18, 2010 | Permalink
  24. Carl - You are the bomb! I asked my host the exact question you suggested and they fixed it! I believe it had something to do with Mod-Security settings. Once they adjusted it export worked perfectly!

    I'm really diggin' this plugin.

    Posted 12 years ago on Friday March 19, 2010 | Permalink
  25. UWEX

    MultiSite doesn't use the /uploads/ folder, and I tried poking around in blogs.dir and various subfolders for the site, but can't find any Gravity Forms related files.

    Is the information in this thread applicable to MultiSite and still current?

    Any ideas what folder I need to look at Permissions on with a MultiSite installation where I don't use /uploads/ ? Thanks!

    Posted 10 years ago on Wednesday December 14, 2011 | Permalink
  26. UWEX, please start a new topic for your issues specifically. Please begin by describing what's not working and what you've done to troubleshoot it. Also, please post what version of Gravity Forms and WordPress you're using, and the file export function was rewritten extensively since this topic was begun.

    Posted 10 years ago on Thursday December 15, 2011 | Permalink

This topic has been resolved and has been closed to new replies.