PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Extra Paragraph Markup

  1. I am creating a post using several paragraph text custom fields. In each paragraph field, on the Advanced tab, I have added a CSS Class Name 'interview-answer', for each one of my answer fields.
    Each post is being sent over in Pending status, is reviewed, and then published (no altering of text at all).

    Two issues when viewing the published post in Firebug:

    (1) The .interview-answer paragraph tags are there, but the post text is not contained within it (see line 3 of pastebin). The text is directly below the paragraph with the .interview-answer class.

    (2) There are EXTRA empty paragraph tags (see line 6 of pastebin), AFTER the paragraph text.

    The strange thing is, that the question custom fields in my form that have CSS Class Name 'interview-question', ARE posting correctly.

    This is an issue some how with the paragraphs only.

    Is this a simple problem on my part, or a bug?

    Thanks much.

    http://pastebin.com/rB6Wp94D

    Posted 7 years ago on Friday June 10, 2011 | Permalink
  2. Hi Munman,

    I just did a quick test and was unable to recreate this issue. Sounds like their might be a stray <p> tag in your content template. If you continuing having issues, try deleting the current field and recreating it from scratch.

    Posted 7 years ago on Saturday June 11, 2011 | Permalink
  3. Hi David,
    Here is the template... http://pastebin.com/TieAD7h1
    No stray P tags....
    I will try to delete and add the paragraph field and see what happens.

    Posted 7 years ago on Saturday June 11, 2011 | Permalink
  4. Hi David,
    I deleted one of the paragraph fields, then recreated it.
    Now the content placed in the form field is not being retrieved back to the post editor screen.
    I looked in postmeta, and the custom field is not being populated with the form field data (anymore, it was before I deleted and recreated the field).
    I triple checked the custom field ID, and it is correct.
    Kinda busted and broken now...
    Any ideas?

    Posted 7 years ago on Saturday June 11, 2011 | Permalink
  5. More information -
    The form entry data for the field IS there. But for some reason is not populating the post custom field now....
    I changed nothing in my template, functions, or anywhere else - except for deleting the paragraph form field, and then recreating it (again, with the correct custom field name).
    I can't find any reason why it would stop populating the post custom field....
    ARGH!

    Posted 7 years ago on Saturday June 11, 2011 | Permalink
  6. Hi Munman,

    If you send me a login to your WP admin and FTP I will take a look: david@rocketgenius.com

    Posted 7 years ago on Sunday June 12, 2011 | Permalink
  7. Hi David,
    I emailed you a login with WP admin access. Thanks!

    Posted 7 years ago on Thursday June 16, 2011 | Permalink
  8. Hi David,
    Just and FYI - the issue regarding populating the post custom field was solved here http://www.gravityhelp.com/forums/topic/paragraph-type-custom-fields-and-create-content-template
    But the problem with the extra markup still there. I am responding to your email regarding that issue.
    Thanks

    Posted 7 years ago on Saturday June 18, 2011 | Permalink
  9. Hi David,
    This issue is now solved, thanks to your email to me.
    I have removed the paragraph markup for each field, and wrapped each custom field with a DIV instead.
    Thanks much!

    Posted 7 years ago on Monday June 20, 2011 | Permalink