PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Extra space after submit button

  1. All of the forms I'm creating with gravity forms are creating extra space on the page after the submit button and before the balance of the text on the page.

    An example of this can be found at: http://gomainstreetmobile.com/every-business-needs-a-mobile-website/ - 2/3 down the page AFTER the video.

    I have tried using Gravity Forms on order pages as well and I'm getting the same error. I did try to amend the style sheet with: .gform_wrapper .gform_footer {
    margin: 0 !important;
    padding: 0 !important;
    }

    But that has not corrected the problem.

    Any assistance would be greatly appreciated.

    Posted 7 years ago on Tuesday April 2, 2013 | Permalink
  2. Something in your theme or another plugin is adding break tags inside your form markup.

    screenshot: http://i.imgur.com/qK7YxhX.jpg

    You need to check for theme/plugin conflicts and see what you can find.

    http://rkt.gs/testing

    Posted 7 years ago on Tuesday April 2, 2013 | Permalink
  3. Your theme or a plugin is messing with the Gravity Forms shortcode output. Please take a look at the invalid HTML being added around the gform_footer. There are extra < br /> tags on every line, and extra closing < /p > tags which do not belong there. Screenshot: http://minus.com/lVRX9Ryozvykw

    You can read about other people's experience with a similar problem here: http://www.gravityhelp.com/forums/tags/raw

    It can sometimes be fixed by adding the [raw] shortcode around the [gravityforms] shortcode like this:

    [php]
    [raw][gravityform id=11 title=false description=false ajax=true][/raw]
    Posted 7 years ago on Tuesday April 2, 2013 | Permalink
  4. One thing I've found is some themes come packaged with a formatter.php or similar script in the functions.php file which allows you to turn off wpautop and wptexturizer via the [raw] shortcode. Organic Themes uses this code in the /includes/formatter.php file. This can yield conflicting results with GF.

    See here: http://css-tricks.com/snippets/wordpress/disable-automatic-formatting-using-a-shortcode/

    If you comment out or remove this file the breaks between hidden input fields are removed. As GF follows WordPress Coding Standards I'd assume they would not account for disabling of automatic formatting.

    As such you may find a grey band appears at the top of GF forms in your theme. Simply add code{display:none;} to your CSS file. Or use Firebug to locate and change CSS values for the code tag. Cheers!

    Posted 7 years ago on Thursday April 25, 2013 | Permalink