PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Extra Space / Padding Under Form

  1. emindy
    Member

    Hello,

    There is too much space under the gravity form on my site (look at the "make an appointment" area: http://goo.gl/kawxF

    I have searched here, and the solution for me is not using [raw][/raw]- that had no effect.

    I put this in my custom css, and it squished all of the fields together, but did nothing to take away the extra padding at the bottom of the form.

    [css]
    body .gform_wrapper form .gform_body ul,
    body .gform_wrapper form .gform_body ul li {
    	list-style-type: none !important;
    	list-style-image: none !important;
    	list-style: none !important;
    	background-image: none !important;
    	background: none !important;
    	padding: 0 !important;
    	margin: 0 !important;
    	border: none !important
    }

    How can I fix this?
    Thank you!

    Posted 7 years ago on Wednesday March 27, 2013 | Permalink
  2. David Peralty
    Administrator

    You have a bunch of line breaks being added to our code. This is usually due to a plugin adding them for some reason. Can you do the following to isolate please? http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 7 years ago on Wednesday March 27, 2013 | Permalink
  3. emindy
    Member

    Okay, I have deactivated every plugin except for Gravity Forms. You will see that the problem is still happening: http://goo.gl/kawxF

    Posted 7 years ago on Wednesday March 27, 2013 | Permalink
  4. It's not a plugin conflict, it's most likely a theme conflict. Have you tested with the default WP theme yet?

    This CSS snippet might help to combat the injected paragraph and break tags coming from your theme:

    [css]
    .gform_wrapper br, .gform_wrapper p {
    display: none;
    }
    Posted 7 years ago on Wednesday March 27, 2013 | Permalink
  5. Just a note.. it's going to be better moving forward if you find out what the actual cause of the extra markup is in your theme and correct that. If you simply use the CSS snippet above.. that fixes the immediate problem with this form, but when you go to add other forms and want to use HTML fields, or descriptions with paragraph tags or breaks then they will be disabled as well.

    This snippet would target on the the form in question.. form ID #1

    [css]
    body #gform_wrapper_1.gform_wrapper br,
    body #gform_wrapper_1.gform_wrapper p {
    	display: none;
    }

    Best of luck with it.

    Posted 7 years ago on Thursday March 28, 2013 | Permalink
  6. Hi Guys,

    I seem to be having the same problem on my site: http://vanguardmastering.com where gravity forms inserts unwanted markup lines. I would greatly appreciate if someone could have a look and let me know if there is a way to remove the unwanted space above and below my gravity forms.

    I have already tried adding the raw brackets etc... doesn't seem to work for me...

    Any support is greatly appreciated. :)

    Thanks and Kind Regards

    Posted 7 years ago on Tuesday May 14, 2013 | Permalink
  7. David Peralty
    Administrator

    Can you please try the instructions listed here - http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 7 years ago on Tuesday May 14, 2013 | Permalink
  8. Thanks for your reply.

    I did the tests as suggested and was able to fix the main issue by using Kevin's code as posted above. However, I am still having one line added to the form just below the submit button, I have checked this with firebug and it seems that gravity form is adding something like this just below each submit button: <p> … </p>

    I would really appreciate if someone could take a quick look at the forms on my site and let me know how to remove this added line.

    http://vanguardmastering.com/

    I have already spent all day trying to figure this out, and would therefor really appreciate any suggestions.

    Many thanks and kind regards, :)

    Posted 7 years ago on Monday May 27, 2013 | Permalink
  9. David Peralty
    Administrator

    You did our Plugin/Theme conflict test? Every single time, without fail, it is due a theme or plugin conflict that is adding these extra paragraph tags or line breaks. If you are experiencing these issues, after having tried both, please let us know.

    Posted 7 years ago on Monday May 27, 2013 | Permalink
  10. I realise that there might be plugin conflict, but this issue can most likely be resolved by you within less than a minute. For convenience I have uploaded a screenshot of firebug inspector here:

    http://vanguardmastering.com/wp-content/uploads/2013/05/Screen-Shot-2013-05-27-at-8.29.32-PM.png

    I won't disable the plugins again as this would take far too long and it wouldn't be an option anyway as I require them for the functionality of the site.

    I have also already contacted the theme developer who has said that this issue is being introduced by Gravity Forms, and adding the code above has already resolved one issue, so its likely that this problem is in-fact caused by your plugin.

    I would really appreciate your support on fixing this simple issue.

    Thanks and Kind Regards,

    Posted 7 years ago on Tuesday May 28, 2013 | Permalink
  11. David Peralty
    Administrator

    I'm positive that if you installed Gravity Forms on a clean WordPress installation, running the default theme, you would see that we don't by default add this in. This is due to Themes adding code in how they deal with shortcodes. This is why we have to tell people sometimes to add [raw] tags around our shortcode so that they don't get processed by the hijacked system.

    The code above, the CSS is just a hack to hide the extra spacing being added by the paragraph tags and line break tags, but not something created by Gravity Forms.

    Which is why Kevin, one of the developers said:

    it's going to be better moving forward if you find out what the actual cause of the extra markup is in your theme and correct that.

    I hope you get this resolved, and please tell your theme developer what I've said in hopes that it leads them to a solution. Believe me, if we could fix this, we would...

    Posted 7 years ago on Tuesday May 28, 2013 | Permalink