PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

FAILED (Temporary file could not be copied.) for uploads

  1. Hello,

    I'm getting the FAILED (Temporary file could not be copied.) for uploads when using a form. What's a bit tricky is that this only happens after I change the owner of my domain to a new user in my web panel (I'm using DreamHost).

    The new owner is needed as there are two of us who need to access the uploaded files, so I created a new owner so that we can both share the FTP info and log in to the uploads folder to access the files. This is what is recommended by DreamHost.

    I've gone back and forth with DreamHost and this is not a problem with any server settings - all of the permissions are correct and all the subdirectories list the new domain owner correctly. I have updated my php.ini to accept large files and this is verified in WP > Media > Add New.

    I have tried all of the solutions suggested in these forums and nothing works. Again, once I change the owner back to me, the uploads work fine. As client submissions are basically the main feature of our site, I really need to get this working.

    Yes, I could give my business partner the original domain owner login/pass but then he has access to all my other domains which I don't want to do.

    Any ideas?

    Posted 9 years ago on Monday March 28, 2011 | Permalink
  2. You may need to discuss this with your web host again. It has to do with the file permissions for the wp-content/uploads folder and the wp-content/uploads/gravityforms folder, it needs to be writeable by whatever user account PHP executes under on your server. If you are getting this message, then the permissions are most certainly not correct.

    Sometimes the permissions you see via FTP, etc. are not the permissions that are being applied to the PHP. What you see are the permissions for your user account. They may not be the same as for the account PHP executes under.

    We had a similar issue when we migrated to FireHost, they made a change which made our uploads folder not writeable. Despite the fact I set the file permissions via FTP and verified they were set correctly, it wouldn't work. FireHost made a change on their end and it began working. It had to do with the account PHP executes as and it's permissions.

    Posted 9 years ago on Monday March 28, 2011 | Permalink
  3. Thanks Carl.

    I tried setting the permissions to 777 via FTP to test and it still didn't work.

    Your response is what I have been saying to DH and they keep responding with: "Everything is set up correctly - it should work." I will forward them this message and see what they say.

    The very fact that it works using the original domain "owner" screams to me that it is a server-side permissions/ownership issue.

    Posted 9 years ago on Monday March 28, 2011 | Permalink
  4. It does to me also, like I said we ran into a similar issue with FireHost. Sometimes it's all about getting the right customer support person at the host. We had similar issues with FireHost, there is always that one guy that doesn't know enough that you get... then you'll get someone that knows everything and solved the problem right away.

    Posted 9 years ago on Monday March 28, 2011 | Permalink
  5. dveiga
    Member

    I'm on a VPS and I've set chmod 777 to both uploads and the gravity_forms folder within and I still get the same error with the latest 1.5 version.

    Any suggestions?

    BTW it did create the folders: gravity_forms > 1 > 2011 > 03 just FYI

    Posted 9 years ago on Monday March 28, 2011 | Permalink
  6. @dveiga The issue sounds like your server can't create the files themselves. The folders are being created, but not the files because it can't write to the server. See the issue above, it could be the same issue. Sometimes setting the CHMOD on a folder doesn't change it for the user that PHP executes as, you may want to check with your web host.

    Posted 9 years ago on Monday March 28, 2011 | Permalink
  7. OK success!

    Everything was set up correctly on the server. The problem was that I was logging in as the old user via FTP to edit the files. So, when I thought I was making changes, they weren't being made in the new owner's directory.

    I had a script in my functions.php that uploaded the files to a different domain/directory. I updated the file path in this script using the old user, so the uploads didn't have write access to the old path (which wasn't being changed no matter how many times I changed it with the wrong user).

    By default, my host copies the files over to the new user so then you have dupes which can be a bit confusing (or maybe that's just me :).

    A simple mistake, but something to look out for.

    And Carl, yes finding the right person is key - this goes for any kind of customer support. I'm surprised no one suggested to me that I was logged in as the old user to edit the files.

    Posted 9 years ago on Tuesday March 29, 2011 | Permalink

This topic has been resolved and has been closed to new replies.