PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

FAILED (Upload folder could not be created.)

  1. vixvii
    Member

    From other forums this looks like it is a PHP safe mode issue, but I need to be sure. I have requested my service provider to look into it for me too, but what confuses me is that this works if I use just the wp_content folder... Only problem is that I need the uploads to go to the root of the uploads folder.

    Could you please verify if I am using the filters correctly below?

    add_filter("gform_upload_path", "change_upload_path", 10, 2);
    function change_upload_path($path_info, $form_id){
       $path_info["path"] = "/wp-content/uploads/";
       $path_info["url"] = "http://fllsa.org/wp-content/uploads/";
       return $path_info;
    }

    Thanks!

    Posted 9 years ago on Friday August 24, 2012 | Permalink
  2. What are the permissions for the wp-content folder and uploads folder within that?

    Your code looks correct. However, can you post the full error? Does it show the path of the folder it's trying to create?

    You may want to turn off DirectoryIndexes on your server:
    http://fllsa.org/wp-content/uploads/

    Posted 9 years ago on Friday August 24, 2012 | Permalink
  3. vixvii
    Member

    Thanks for the reply. My service provider confirmed that PHP safe mode is off, but I still have the error. Unfortunately I cannot see exactly what path it is trying to create, I only get the "FAILED (Upload folder could not be created.) " error in the admin confirmation message.

    wp-content has permission 755 and uploads I changed from 755 to 777 when this problem started.

    I initially had the path as "wp-content/uploads" (without the front and back slashes) and then it uploaded the file inside wp-content as uploadsfilename.ext

    I have asked for directoryindexing to be turned off too.

    Posted 9 years ago on Friday August 24, 2012 | Permalink
  4. vixvii
    Member

    Update : After posting my reply I thought to try removing the first "/" of the path and now it works! ("wp-content/uploads/")

    Thanks!!

    Posted 9 years ago on Friday August 24, 2012 | Permalink
  5. Glad you were able to resolve that. Thanks for the update.

    Posted 9 years ago on Friday August 24, 2012 | Permalink

This topic has been resolved and has been closed to new replies.