PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Fatal error: Allowed memory size when adding new gravity forms

  1. I have a site where I'm using a number of Gravity Forms (about 10 different forms). I need to add a few more but I'm starting to get error messages like the following about allowed memory size. Any ideas if this is related to Gravity Forms? That is all I have been working on so maybe there is some limit to the number / complexity of forms on a site?

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 90 bytes) in /home/cyrijones2/httpdocs/wp-includes/load.php on line 552

    Thanks.

    Posted 11 years ago on Monday September 6, 2010 | Permalink
  2. obvio
    Member

    same here..

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 77824 bytes) in /Users/~/Site/wp-admin/includes/schema.php on line 710

    this is the 1.4 beta

    Posted 11 years ago on Monday September 6, 2010 | Permalink
  3. Interesting. cyri has a 256MB allowed and obvio has just 32MB.

    What version of WordPress? And what version of PHP? (there is a version_compare for PHP in load.php).

    For obvio, I think I would try to get more memory for PHP.
    http://wordpress.org/support/topic/plugin-google-xml-sitemaps-xml-sitemap-memory-limit-problem#post-1595661

    For cyri, I think there is something else going on, since PHP really shouldn't suck up 256MB of RAM.

    Posted 11 years ago on Tuesday September 7, 2010 | Permalink
  4. Thanks illinoisharley for the tip about something else probably going on.
    I'm using WP 3.01 and I believe PHP 5. I'm using the 1.4 beta version of Gravity Forms.
    I will try deactivating all my plugins except Gravity Forms and see if I still get the error.

    Posted 11 years ago on Tuesday September 7, 2010 | Permalink
  5. @cyri there could also be something going on with your PHP setup in general, not just plugin related. It does seem like a lot of memory to be using and there aren't any known issues with Gravity Forms causing this type of problem so it's most likely something unrelated to Gravity Forms as other people would be reporting the issue if it was a bug.

    Posted 11 years ago on Tuesday September 7, 2010 | Permalink
  6. Thanks Carl. I will take a closer look at my PHP set up in addition to my other plugins.

    Posted 11 years ago on Wednesday September 8, 2010 | Permalink
  7. In some instances you can increase the memory limit for WordPress via the wp-config.php file. This may help, but it depends on how much is allotted by your web host.

    Increasing memory allocated to PHP

    Also released with Version 2.5, the WP_MEMORY_LIMIT option allows you to specify the maximum amount of memory that can be consumed by PHP. This setting may be necessary in the event you receive a message such as "Allowed memory size of xxxxxx bytes exhausted".

    This setting increases PHP Memory only for WordPress, not other applications. By default, WordPress will attempt to increase memory allocated to PHP to 32MB (code is at beginning of wp-settings.php), so the setting in wp-config.php should reflect something higher than 32MB.

    Please note, this setting may not work if your host does not allow for increasing the PHP memory limit--in that event, contact your host to increase the PHP memory limit. Also, note that many hosts set the PHP limit at 8MB.

    Increase PHP Memory to 64MB

    define('WP_MEMORY_LIMIT', '64M');

    Increase PHP Memory to 96MB

    define('WP_MEMORY_LIMIT', '96M');

    http://codex.wordpress.org/Editing_wp-config.php

    Posted 11 years ago on Tuesday September 14, 2010 | Permalink
  8. lalomarquez
    Member

    Thank you Kevin, it worked for me. Best regards, Ed.

    Posted 11 years ago on Thursday April 28, 2011 | Permalink