PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Fatal Error caused by "Maximum execution time of 30 seconds exceeded"

  1. Hi Carl,

    I've been using Gravity Forms on a client website for ages, with no problem at all. Then a few days ago, we started getting a white screen with this fatal PHP error:

    Fatal error: Maximum execution time of 30 seconds exceeded in /home/debb1003/public_html/wp-includes/class-http.php on line 1060

    Nothing had changed. I've deactivated all other plugins and still get the error. However, nothing about the environment has changed, so I'm not sure what's causing this problem.

    Any suggestions? Client is depending on GravityForms, so this is a BIG issue.

    Posted 11 years ago on Thursday February 10, 2011 | Permalink
  2. This is a web server issue. Your PHP max execution time is too low. I found another thread on WordPress.org that discusses the same issue:

    http://wordpress.org/support/topic/failed-upgrade-to-301

    Posted 11 years ago on Thursday February 10, 2011 | Permalink
  3. Hi Carl

    30 seconds execution to load a dashboard, sounds very excessive. I'd expect it to load within 2-4 seconds. This is not for upgrading or installing a plugin, this is for just logging in, nothing else! So it seems as if there's something going wrong with the plugin, such as doing a cURL execution or something that's timing out....

    Dan

    Posted 11 years ago on Thursday February 10, 2011 | Permalink
  4. @DanHarrison There is nothing wrong with Gravity Forms, you are the only user reporting this issue and there are currently over 110,000 unique WordPress sites running Gravity Forms. This is a site specific issue, not a plugin issue. If this issue just started happening out of the blue, nothing has changed with the Gravity Forms code so something else is going on. The code isn't going to just start executing differently for no reason.

    Like I said, you may need to look at the PHP execution timeout setting. It may also be a PHP memory issue or a MySQL memory issue. Although looking up this error on Google as it related to WordPress returned numerous results unrelated to Gravity Forms. So it could be a WordPress related issue.

    Posted 11 years ago on Thursday February 10, 2011 | Permalink
  5. Hi Carl

    Must admit, I was a bit disappointed and upset by your reply.

    I'm fully aware that this is a site-specific problem. However, Gravity Forms is the only plugin (in this installation) that's causing the error (which shows just when trying to show any part of wp-admin - nothing to do with installing/uninstalling a plugin). Increased memory size, increased timeout period. No different in behaviour.

    Tried the base theme, no difference. Enabling WP_DEBUG yields no useful information either.

    I suspect there's a cURL timeout or infinite loop happening, most likely due to errors in the configuration settings. I was hoping for some ideas of where to look so that I could debug the issue.

    Dan

    Posted 11 years ago on Thursday February 10, 2011 | Permalink
  6. @DanHarrison What I am trying to explain is if there was a bug in Gravity Forms causing an infinite loop it would be happening to our entire user base. Nobody else is experiencing the issue. There isn't any configuration settings that would cause an infinite loop simply by viewing the WordPress dashboard. I don't think the timeout issue is Gravity Forms specific issue, I think it is a web server configuration issue. If it just started happening out of the blue then something on that server changed.

    Posted 11 years ago on Thursday February 10, 2011 | Permalink
  7. I'm well aware (as a developer) that there's not a change in the codebase, but all it takes is for some screw up in configuration data (e.g. in MySQL) for a plugin to start misbehaving due to an assumption about data formats.

    I do know that the mailchimp Add On was doing something screwy a few days ago, but I thought it would pass. Not sure if it's related, but it might be. Although I've already disabled the mailchimp code.

    I tried the beta code, no difference. I tried removing all gravity forms tables from the database, no difference. By process of elimination, I have to agree it's some quirky server configuration that's been changed.

    I hope.

    Regards
    Dan

    Posted 11 years ago on Thursday February 10, 2011 | Permalink
  8. There isn't too much in the way of database configuration for Gravity Forms, especially if you have tested with no forms existing. The only settings are the license key and a couple options for displaying CSS/JS. So there isn't much to go wrong as far as that goes. The form data itself is then only utilized when a form shortcode or function call is executed, so it wouldn't cause any issues with just the Dashboard displaying.

    The MailChimp Add-On relies on the MailChimp API. So if MailChimp is experiencing an issue, that can cause problems with executing forms that interact with the MailChimp API but at worst they wouldn't complete the process and the data wouldn't be passed to MailChimp.

    Posted 11 years ago on Thursday February 10, 2011 | Permalink
  9. I'm going to take a site copy, and test it on some different hosting. That should yield conclusively if there's a configuration issue or a server issue.

    Thanks for the help Carl.

    Dan

    Posted 11 years ago on Thursday February 10, 2011 | Permalink