PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

field editing in 1.5 doesn't work

  1. I'm just trying to get a new client's site working with Gravity Forms 1.5, and the field editing doesn't seem to work. I'm on WP 3.1, using Google Chrome 10.

    When I create a new form, and click to edit the main form settings (title etc.), the "Properties" link doesn't do anything. "Advanced" opens up the fields to edit the title and description, and "Confirmation" seems to work.

    When I add any fields, and click to edit, neither "Properties" nor "Advanced" do anything. The JS console shows no errors. I've tried every combination of saving, editing, deleting, etc., but I cannot edit any fields.

    I wondered if this was anything to do with not having a license key. I have a single site key myself, but the client hasn't bought one for their site yet. I thought I would download the latest version of GF and get it working on the dev site before the client gets round to buying their key. I've tried removing the key from the site I have it on and entering it into this site, but no luck. Besides, from what I understand, the key is just for support and one-click upgrades, and a lack of a key shouldn't disable any functionality.

    I've searched the forums and found slightly similar issues, but no solutions. I've cleared my browser cache and restarted. I've tried Firefox.

    I've run out of options and I've got a really tight deadline! Help appreciated.

    Posted 10 years ago on Monday March 28, 2011 | Permalink
  2. It should not have to do with not having a license key. It sounds like some sort of conflict (theme or plugin). You would have to check for conflicts.

    To test for a theme conflict:

    - Activate default Twenty Ten theme
    - Check to see if the issue still occurs

    If it does not, then something in your theme is causing a Javascript conflict on the Gravity Forms form editor page. If it still happens, follow the steps below to test for plugin conflicts.

    To test for a plugin conflict:

    - Deactivate ALL plugins
    - Activate Gravity Forms
    - Check to see if the issue occurs

    If it does not, then one of your plugins is causing a Javascript conflict on the Gravity Forms form editor page. To narrow it down follow the steps below:

    - Activate each plugin one by one
    - Check to see if the issue occurs after each one

    Let me know how it goes. We can't prevent themes or plugins from causing conflicts if they output code on our admin pages. This can happen when the plugin or theme doesn't isolate when and where it outputs it's scripts.

    Posted 10 years ago on Monday March 28, 2011 | Permalink
  3. Got it. Some weird conflict with my theme's JS.

    Thanks for the patient and detailed response, Carl - wish I could finally learn to do the debug basics before posting ;-)

    Posted 10 years ago on Monday March 28, 2011 | Permalink
  4. Your next step will be to see why your themes JS is loading on that page and implement code to only output the JS on the front end or on admin pages where it is necessary. It's a common mistake to globally output scripts, and that is when conflicts are introduced.

    Posted 10 years ago on Monday March 28, 2011 | Permalink
  5. Lee Hord
    Member

    I have the same problem of sorts but with only one form. However I do receive the following error in the console:

    Result of expression 'jQuery(".field_selected")[0]' [undefined] is not an object.

    Can't figure this one out, tried default theme, turning off all plugins, even recreating the form from scratch and it still does this, strange as all my other forms are okay.

    Posted 10 years ago on Tuesday March 29, 2011 | Permalink
  6. Lee Hord
    Member

    Figured it out. If you create a form and add a post body field and set it it use content template, then leave the field blank then save go away and then come back to the form it stops you from editing the fields.

    Posted 10 years ago on Tuesday March 29, 2011 | Permalink
  7. Thanks for the replication steps, we'll take a look and see what is going on.

    Posted 10 years ago on Tuesday March 29, 2011 | Permalink
  8. Raquel_P
    Member

    I'm having the same problem that Lee Hord. I can not edit the fields or drag and drop. Nor can I access two types of lower fields (post pricing and fields), because I cannot close the menus above.

    I am using Firefox 3.6.16, Wordpress 3.1.1 (multisite) and Gravity Forms 1.5.1.1

    I have already changed the permissions for Gravity Forms Javascript and JQuery files (755) and have disabled all plugins and themes:
    - Explanatory Dictionary 2.0
    - Custom Post Type 0.7 IU
    - Gravity Post Types Custom Forms + 2.0
    - Akismet 2.5.3
    - BuddyPress 1.2.8
    - BP - Default Theme

    Posted 10 years ago on Sunday April 10, 2011 | Permalink
  9. @Raqel To help us determine what is going on, did you do what Lee described above?

    "If you create a form and add a post body field and set it it use content template, then leave the field blank then save go away and then come back to the form it stops you from editing the fields."

    Posted 10 years ago on Monday April 11, 2011 | Permalink
  10. Raquel_P
    Member

    Exactly, but in my case was the title field.
    If you add new fields ... solves the issue temporarily, enough to erase the title field that caused the crash.

    Posted 10 years ago on Monday April 11, 2011 | Permalink
  11. Okay, we'll look into this and see what is going on and correct the issue with the Content Template.

    Posted 10 years ago on Monday April 11, 2011 | Permalink
  12. Lee Hord
    Member

    There is kind of a janky workaround to this problem where you can delete the offending field causing the problem. You'll need to use Developer Tools in Chrome/Safari or Firebug in Firefox.

    • Use the select element to inspect option and choose the field you know is causing the issue, in my case it was a post body field.
    • Now choose the container LI within the Source View and double-click within the class tag and type "field_selected" without quotes.
    • This will then show you the Edit and Delete options, you won't be able to edit, but you can Delete the field and then recreate as required.

    Hope this is of some help until there is a fix.

    Posted 10 years ago on Thursday April 14, 2011 | Permalink
  13. We've recreated the issue and it will be fixed in the next release. Thanks!

    Posted 10 years ago on Thursday April 14, 2011 | Permalink
  14. I have a similar problem on one site where it seems the form editor JS is not loading correctly or at all. I'm trying to create a new form and I don't even see the form properties controls that appear by default when adding a new form.

    The weird thing is that, this is a bilingual site but one of my first (originally created in WP 2.9.2) so it's two separate WordPress installs (instead of a 2 sites multisite network as I usually do now) one in the root (French) and one in a "/en/" sub folder (English). The two installs use the same theme (Headway 2.0.9) and all the same plugins yet, Gravity Forms in the subfolder WP install works fine but the one at the root doesn't.

    I've tried in both Firefox and Chrome with the same results. I tried deactivating and reactivationg GF, reuploading the plugin files (including all the wp-admin and wp-includes files), cleared the cache several times, etc. I tried importing a form I created in the english version of the site and the form imports in the editor but none of the editing controls show and I cannot reorder or add new fields.

    I really have no idea what might be going on here so I'D appreciate a little help. I can send login details if needed.

    Thanks!

    Posted 10 years ago on Friday April 15, 2011 | Permalink
  15. @stephane This doesn't sound like the same issue as the users above, in the future please be sure to start a new forum thread. The users above had issues with a theme conflict and a bug with the Content Template functionality. Yours sounds more like a server related issue. If you send us the WordPress admin login details and a description of the problem via our Contact Us form we'll take a look.

    Posted 10 years ago on Friday April 15, 2011 | Permalink
  16. Hi again!

    I figured out where the issue comes from: my French translation files. If I remove them the form editor works again.

    I just went through every string again (I spent a LOT of time doing the full translation last week) and found nothing that could explain the break. I uploaded them on my site in case you have tools to "validate" them or something. Both the .po and .mo files are in the ZIP.

    The first ZIP contains the files created with the Codestyling Localization plugin (my preferred method as well as the ones edited in POEdit. Both .mo files break the form editor but I have no idea why.

    http://www.webfocusdesign.com/files/gravityforms-fr_FR.zip

    http://www.webfocusdesign.com/files/gravityforms-fr_FR_poedit.zip

    Thanks!

    Posted 10 years ago on Friday April 15, 2011 | Permalink
  17. Sorry about that Carl. At first I really thought it was a similar issue until it came to me to check the translation files. Do you want me to start a new thread now or will you try to figure things out with the info in my last post? It is indeed neither a theme or plugin conflict nor a server issue as GF works OK without the translation files.

    Thanks!

    Posted 10 years ago on Friday April 15, 2011 | Permalink
  18. We'll try installing your translation locally and see if we can reproduce the issue and narrow down what is causing the problem.

    Posted 10 years ago on Friday April 15, 2011 | Permalink
  19. Hello,
    I am having a theme Javascript Conflict. Not able to use the form editor like the users above. Can you help me figure out a way to debug the issue? I don't know much about Javascript or how to follow the errors to the problem. I just know that when I switch the theme to Twenty Ten it all works fine. If it helps this is the theme I am using http://themeforest.net/item/delericon-businessportfolio-template-wordpress/full_screen_preview/76635

    I also tested for plugin conflicts and there are none..

    thanks

    Posted 10 years ago on Monday April 18, 2011 | Permalink
  20. What is going to be happening is that theme is outputting javascript in the admin when it should only be outputting javascript on the front end. If you email me a copy of that theme to carl@rocketgenius.com I can take a look at it and see what needs to be changed.

    Posted 10 years ago on Tuesday April 19, 2011 | Permalink
  21. Carl,
    Thanks so much for the quick reply. I emailed you a copy of the theme. You should have it shortly.

    Posted 10 years ago on Tuesday April 19, 2011 | Permalink
  22. ksnyde
    Member

    I think I'm having a similar problem Carl but it's possible it's a different variant. I'm certainly on a newer release as time has moved on. Anyway, the problem manifests itself when I open a new form or edit an existing form for editing. I see the accordion of different fields to choose from and if I mouse over the text it turns red and highlights clearly recognising the mouse event. I then try and drag the object onto the form and in 95% of cases it just ignores the action and nothing happens. Occasionally, and I notice no pattern to this, it drops the field to the bottom of the form. At the point that it successfully makes it onto the form I am able to edit with no problems (aka, move position and modify the attributes of the field).

    I'm using version 1.5.3 of gravity forms and Wordpress 3.2.1. My website is http://lifegadget.co (please ignore it's very rough look and feel as I'm just getting started).

    Posted 9 years ago on Thursday October 27, 2011 | Permalink
  23. @ksnyde, you don't drag fields in the form builder. You add them by clicking. Is that what you're doing?

    The form field is supposed to be added to the bottom of the form when you add it. After you add it, you can drag it to whatever position you want in the form.

    It sounds like it's working properly.

    Posted 9 years ago on Friday October 28, 2011 | Permalink
  24. ksnyde
    Member

    Hi Chris,

    Yeah I wasn't sure if clicking or dragging was required so I've tried both to the same effect (aka, 95% of the time nothing happens, 5% it does and all fields that are on form behave correctly).

    Ken

    Posted 9 years ago on Friday October 28, 2011 | Permalink
  25. ksnyde
    Member

    Just a side note, I tried this using Firefox too just to see if it was a problem with Safari. Same result. Both browsers are on the Mac side of the fence (for what that's worth).

    Posted 9 years ago on Friday October 28, 2011 | Permalink
  26. This is not how the form builder normally works. Most of the team at Gravity Forms uses Mac, so that is not the problem.

    Can you try creating a new form, and click to add a new field and explain what happens?

    Anything else interesting or different about your set up? Any admin plugins for WordPress?

    Posted 9 years ago on Friday October 28, 2011 | Permalink
  27. ksnyde
    Member

    Well I've figured it out. It had to do with the fact that my hosting provider's default install of Wordpress comes with quite an obtrusive advertisement for the "Jetpack" plugin which I'd been ignoring but it appears that having it there visually offset the Gravity Forms accordion widget as you'd see it vertically overlapping with the standard grey bar of the Form Editor (aka, "form editor", "form settings", "notifications, ... ). I added the JetPack and the advert went away and Gravity Forms immediately started working.

    Not a very technical way of describing things I know but a happy ending none-the-less. Thanks for your attention Chris and if you have any clearer observations from a technical standpoint I'd be all ears to hear them but otherwise consider my problem solved.

    Posted 9 years ago on Saturday October 29, 2011 | Permalink
  28. If adding the jetpack worked to get rid of the advertisement, then that's a valid solution. It's hard to say what the conflict was, but if you got it fixed, I'm happy it worked for you.

    WPMU Dev does something similar with ad 'ad' you can't remove. I wonder if anyone has ever had a problem with that?

    Posted 9 years ago on Saturday October 29, 2011 | Permalink
  29. I found by deactivating the plug in WP Email-to-Facebook plugin
    it resolved this probelm

    Posted 8 years ago on Wednesday November 28, 2012 | Permalink

This topic has been resolved and has been closed to new replies.