PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Fields populated dynamically not showing up in email

  1. Hi guys

    I have created a form that opens via Fancybox. Two fields are required to be pre-populated in that form and so I'm passing these via a URL parameter.

    The form is receiving these parameters fine, as you can see here: http://cl.ly/2z05052q0v2u0W1I2C46

    In the notification settings, I'm calling these fields as directed: http://cl.ly/2k2T2O471V1C2D3f3s05

    However the email I'm receiving, the dynamically populated fields aren't showing up: http://cl.ly/151L3S0F0W3W1a0m3c0d

    Can anyone assist me with a reason why this is happening please?

    Thanks!

    Posted 7 years ago on Wednesday October 19, 2011 | Permalink
  2. I can't really see any text in the first image you linked to, but that might just be my monitor.

    It looks like you're doing it correctly. Can you try removing the quotes around {Product:6} and see if that has any effect? Maybe the merge tag is not being parsed properly when it encounters quotes like that. You could use HTML like < strong >{Product:6}</ strong > around it, or < em >{Product:6}</ em >. It looks like the name is working properly.

    If removing the quotes allows it to work properly, we can look into why it's happening in the first place.

    Also, what version of Gravity Forms are you using?

    Posted 7 years ago on Wednesday October 19, 2011 | Permalink
  3. Hi Chris. Thanks for your reply...

    There's 2 areas where dynamic fields are being called. One has quotes around it, and the other doesn't. Neither are working, so I don't think quotes are the issue.

    Your friend {Your Name:1} thought you might like this "{Product:6}" product listed on Born With Style.
    {URL:7}

    Product:6 and URL:7 are the 2 'dynamic' fields.

    I'm using the latest version, Version 1.5.3.

    Posted 7 years ago on Wednesday October 19, 2011 | Permalink
  4. Oh, there are 3 places there. Got it. The one field that is not populated dynamically (name) is working OK?

    Can you try it without quotes though, just as a test? Maybe if the parser encounters quotes, it stops, or something. Just troubleshooting.

    I can't see how you're populating the fields though. Can you share a link to the form? It's possible the fields are not making it into the entry.

    That's a good question. Are the dynamic fields being stored properly with the entry, or are they missing there too?

    Posted 7 years ago on Wednesday October 19, 2011 | Permalink
  5. Hi Chris

    No, there's just the 2 fields that are dynamically populated: Product:6 and URL:7.

    The fields are hidden fields in a form. The values are being posted to the form, as you can see in the code here: http://cl.ly/0x3V3o0i433l241D1j0E

    Good point, the data isn't being saved/stored either: http://cl.ly/2R0U0a1U3O3p3A3Y2G3b

    I dont want the user to change the values in these 2 fields, so I've set them (via jQuery) as 'disabled'. Is this perhaps why GForms is ignoring the data?

    Posted 7 years ago on Thursday October 20, 2011 | Permalink
  6. Confirmed: removed the disabled attribute (was moot because the fields are hidden with CSS anyways) and it now works fine.

    My bad :P

    Posted 7 years ago on Thursday October 20, 2011 | Permalink
  7. Glad you got that resolved. Thanks for checking into that.

    Posted 7 years ago on Thursday October 20, 2011 | Permalink

This topic has been resolved and has been closed to new replies.