PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

File Upload

  1. Hi,
    I'm working with http://awakenedmutuality.org to add to the form we have online. I'm wanting to add the file upload field on a form. For the life of me I can't figure out where the uploaded files are, or even if the upload is working. When I submit the form, I receive an email notification as we expect. It doesn't have a link to an uploaded file or include it as an attachment. (Because our site is live, I'm testing this on a remote development server). There seems to be something pretty basic I'm missing?

    Thanks for your help.
    Bill

    Posted 9 years ago on Wednesday March 30, 2011 | Permalink
  2. The uploaded files using the File Upload field would be stored in your wp-content/uploads/gravity_forms folder, it will create subfolders there.

    Any uploads would be visible on the Entry Detail page when you view an entry that was submitted. It would list all the form field data that was submitted and link to any uploaded files.

    When using the {all_fiels} variable in your Notification emails, this would also include links to any files that were uploaded with the form in the notification email.

    Posted 9 years ago on Wednesday March 30, 2011 | Permalink
  3. Thanks for your response Carl. So, here's what I've done: I resent a test message with a small txt file upload and received the notification (the {all_fields} variable is in my notification config). There was no link or other indication that a file was uploaded. Checked the server and saw that no gravity_forms folder had been created in the uploads folder. SO, I created a gravity_forms folder in the uploads folder, thinking maybe that was the step I missed. Then re-did the test email with txt file upload, etc again. Still nothing.

    Any idea where to go from here? Thanks again.
    Bill

    Posted 9 years ago on Thursday March 31, 2011 | Permalink
  4. It's a file permission issue. Gravity Forms is unable to write to that folder. If you have PHP Safe Mode turned ON on your web server, this could prevent it from being able to write/create folders and files to your server.

    Posted 9 years ago on Thursday March 31, 2011 | Permalink
  5. Thank you Carl.
    I'll look into that and get back to you :) I appreciate your help.
    bill

    Posted 9 years ago on Friday April 1, 2011 | Permalink
  6. Hi Carl,
    Well, sorry to say I'm back :). So, according to our host, it isn't a permissions issue. I'm pasting below the response from Dreamhost support, beginning with their response to my initial 'it's not working, can you help?' question:

    Hello!

    I'm sorry to hear you're having issues with your account :/

    PHP Safe Mode is off on our apache servers.

    I've checked the upload directory and the directory does have the correct
    permissions. The folder is set to 755, which is fine for WP to write to
    and create directories.

    Please make sure you've got the correct path specified in your
    settings/code as it doesn't actually seem to be a permissions/CHMOD
    issue.

    Let me know how it goes or if you need anything else.

    > Well, that's still not working :( Unless you have an additional thing or two
    > for me to try, I'll bounce back to Gravity Forms support with this further
    > information to see what they have to say.
    >
    > Thanks for your attention to this; I may be back later :)

    Hello again!

    I've run into a similar issue before, but the file path was being coded.
    Usually, a permission error from within WP is due to a bad path (ex. bad
    media upload path).

    You may want to check if there's *any* path being specified in one of the
    .php files.

    So I guess my further question is regarding where the path for the file upload is being designated in the plugin. Or do you have another suggestion?
    Thanks again.
    Bill

    Posted 9 years ago on Saturday April 2, 2011 | Permalink
  7. The path is your wp-content/uploads folder. Gravity Forms then creates a gravity_forms folder there where it stored any files that are uploaded and creates additional subdirectories.

    Just FYI, web hosting is all about which support person you get. We had issues with our own host where we were told file permissions were set properly when really they were not. We didn't learn this until we discussed it with another support person who realized file permissions appeared to be correct, but not for the user account that the PHP was executing as. So never rule that out.

    Posted 9 years ago on Monday April 4, 2011 | Permalink
  8. kezsuzsi
    Member

    Hi,

    My issue is connected to the one mentioned in this post.
    Instead of the attached file, I get the "FAILED (Temporary file could not be copied.)" error message. I checked the permissions and they seem alright. The file structure is created, but the file is not copied in. Can you point we in the right direction to find the cause of this error?

    Thanks,
    Zsuzsanna

    Posted 9 years ago on Friday July 8, 2011 | Permalink
  9. The "FAILED (Temporary file could not be copied.)" error message is a server error message related to file permissions. It's the error that occurs when the file can't be copied due to file permissions. Sometimes the file permissions you set via FTP are not the file permissions that are used by PHP executing on your server, the user the PHP executes may have different permissions. You may need to discuss this with your web host.

    Posted 9 years ago on Friday July 8, 2011 | Permalink