PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

File upload not working at all

  1. Hi, I'm using a gravity form for site visitors to create a post on my site. The form features a file upload facility.

    The form is creating a post properly, but despite the file appearing to be accepted for upload, no image appears to get uploaded.

    I have tried opening up the file permissions to 777 from 755 on both the Gravity Forms folders and the normal WP media library folders, but it doesn't make any difference.

    Strangely, when I manually add an image to a visitor post that should have had an image using the standard WordPress post editor, it appears twice in the post!

    Posted 5 years ago on Monday May 13, 2013 | Permalink
  2. I am having a very similar issue. I have users creating a Post (Draft) and all things are working smoothly, except when they do a File Upload (PDF file), it doesn't appear anywhere in the Post, the Entries, nor in the WP Media Library. I see it in the FTP folder, but would rather not have to go in and manually attach to each Post.

    Anybody have an idea?

    Posted 5 years ago on Monday June 17, 2013 | Permalink
  3. Hey Bryan,

    I solved my problem - and it may solve yours as well!

    There are TWO file upload controls. The one you want is marked "Image" in the Post section.
    I was using the "File Upload" control in the Advanced Fields section, which won't work for post forms.

    Why it should be called something different I have no idea!

    Hope this helps you!

    Posted 5 years ago on Monday June 17, 2013 | Permalink
  4. Zen - when you used the "Image Upload" were you able to upload other file formats than just images? Could users upload PDFs, DOC, DOCx?

    Posted 5 years ago on Tuesday June 18, 2013 | Permalink
  5. Afraid not - the image upload is limited just to image types. Trying a PDF or anything other than a recognised image file type will produce an error message.

    Posted 5 years ago on Wednesday June 26, 2013 | Permalink
  6. Richard Vav
    Administrator

    If you still require assistance with this please open a new support ticket or a priority support ticket if you are a developer license holder. Thank you.

    Posted 5 years ago on Sunday July 28, 2013 | Permalink

This topic has been resolved and has been closed to new replies.