PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

File Upload - Saving special characters as urlencoded

  1. We have a client that uses Gravity forms for accepting Resumes. There are numerous instances where the given Resume File name contains a space or some other special character. For Example:

    John Smith Resume.docx is saved as John%20Smith%20Resume.docx - which when linking to the file to download it doesn't work - the file handler or whatever on the server end is stripping out the %20 automatically and is looking for the file with spaces, however, the file is saved with the %20s

    I don't think this is a good feature to be honest, but I think at the least it should be able to be toggled as an option. As it stands now I'm seeking a good solution for them. Hacking core code and having to "fork" Gravity forms essentially to keep updates from overriding is a very last resort, but it's gotta be done - the client needs it.

    Any thoughts?

    Posted 7 years ago on Tuesday July 17, 2012 | Permalink
  2. I just uploaded a .docx file on my dev site and it converted it and the path name like this:

    Uploaded: Test Word Doc.docx
    In the entry and url path: Test-Word-Doc.docx

    Posted 7 years ago on Tuesday July 17, 2012 | Permalink
  3. Well, I guess it could be a server setting that is causing it, but I assure you, I'm up to date on GF and it is saving it as such:

    https://dl.dropbox.com/u/7659824/file-originally-saved-as.png

    The file download:

    http://www.westsoundworkforce.com/cms/wp-content/uploads/gravity_forms/2-484b8620b3b2b235ca0d616d82111853/2012/07/SARGUS%2C+CHRISTINE.docx

    If it's not gravity forms though, what can I do to remedy this? I can put in a support ticket to our support company but they don't support software so I have to be certain it is on their end. :)

    Posted 7 years ago on Tuesday July 17, 2012 | Permalink
  4. Since we are both running the latest version of Gravity Forms - I think we can rule Gravity Forms out as the culprit. I'd see if it is a host setting of some kind.

    Posted 7 years ago on Tuesday July 17, 2012 | Permalink
  5. Hello Rob,

    This is now resolved. I submitted a ticket and they insisted it was a software issue, but they found a case on the forums where there was an outdated version of GF that was the culprit. Our version was current, but there was an update to WordPress 3.3.x to 3.4.1 and upon updating WP itself, this issue seems to work. At least for now!

    Thanks again!

    (no idea what would cause that, but just FYI for others)

    Posted 7 years ago on Tuesday July 17, 2012 | Permalink
  6. Right on, this is definitely proof in the pudding that keeping up to date with WordPress and all plugins is crucial for expected functionally going forward. Glad you got it working!

    Posted 7 years ago on Tuesday July 17, 2012 | Permalink

This topic has been resolved and has been closed to new replies.