PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

File upload URLs are 404

  1. Although FTP shows the file as uploaded, and I can download the file to my computer via FTP, it's 404 at the URL for the single post:

    http://ohalah.org/references/resource-1/

    File uploads were fine until recently, when the WP site definition was changed from https://ohalah.org to http://ohalah.org. Do I need to change some GF setting in response?

    Beth

    Posted 7 years ago on Tuesday June 5, 2012 | Permalink
  2. Does the folder structure of that link to the PDF match when you view via FTP?

    Posted 7 years ago on Tuesday June 5, 2012 | Permalink
  3. Yes. Just double-checking my work --

    The link on the single post:
    http://ohalah.org/wp/wp-content/uploads/gravity_forms/1-a311efdeab2881d6e166c4653898f825/2012/06/ed17.pdf

    The folder structure associated with that PDF in the FTP client:
    ohalah.org/wp/wp-content/uploads/gravity_forms/1-yaddayadda/2012/06/ed17.pdf

    Yep. Looks the same to me. Am I missing something?

    Posted 7 years ago on Wednesday June 6, 2012 | Permalink
  4. Beth, I'm thinking this is related to a permalink issue of some kind, since you changed the domain value. Maybe try going into the permalinks settings and updating it. You can keep the same structure, maybe just update it to refresh.

    Usually when you get 404's on things that exist it's tied to a permalink or a permissions issue on the server.

    Posted 7 years ago on Wednesday June 6, 2012 | Permalink
  5. Yeah, I saw that issue elsewhere, so I updated the permalinks settings before posting here. Twice. No joy. I've also deactivated and reactivated the GF plugin, but that hasn't helped either.

    Posted 7 years ago on Wednesday June 6, 2012 | Permalink
  6. I've also created a new form and tested it. Same problem.

    Posted 7 years ago on Wednesday June 6, 2012 | Permalink
  7. Could you provide me with FTP access by chance? rob@rocketgenius.com and reference this post in your email.

    Posted 7 years ago on Wednesday June 6, 2012 | Permalink
  8. I wish. But I don't have the authority to do that. The file is being uploaded all right, and to the right place. The file permissions are all good.

    Oh, wait. It's some kind of conflict with the plugin User Access Manager. When I deactivate that, the file shows up just fine. Hmm. What's my next step?

    Posted 7 years ago on Thursday June 7, 2012 | Permalink
  9. Never mind about a next step. Problem solved! After deactivating UAM and then reactivating it, the file uploads -- and new file uploads -- still work. Yay!

    Posted 7 years ago on Thursday June 7, 2012 | Permalink
  10. David Peralty
    Administrator

    Interesting issue. I'm glad it wasn't directly related to Gravity Forms. You might want to let the creator of the User Access Manager know about the issue you experienced as they might be able to fix it in a future release.

    Posted 7 years ago on Thursday June 7, 2012 | Permalink

This topic has been resolved and has been closed to new replies.