PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form is Not Saving Entries - No Notifications Are Being Sent

  1. eirlymeyer
    Member

    Just had some customers fill out my form - using gravity forms.
    I have a form where people are sent from PayPal, redirected to a form on a page.
    Here is the form: http://mementomarketing.com/memento-ranking-service-premium

    The form has previous entries, and has been working.
    Today, I find out that it suddenly isn't.
    I have the following:
    1. WordPress 3.4.1.
    2. Latest version updated (Version 1.6.5.1 ).
    3. No new plugins or anything has been added, except automatic updating of the latest theme.

    Posted 6 years ago on Friday August 10, 2012 | Permalink
  2. This is likely due to incompatible jQuery versions, or multiple versions. Looks like jQuery is being loaded from googleapis, and there are multiple versions included. It's resulting in this error:

    Timestamp: 8/10/2012 8:21:50 AM
    Error: ReferenceError: jQuery is not defined
    Source File: https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.16/jquery-ui.min.js?ver=3.4.1
    Line: 18

    The goal should be to load one version of the library, and ensure that is loaded in the page before Gravity Forms needs it (i.e. in the header rather than the footer.)

    I think once you resolve that issue your form will work again. That page has a lot of JavaScripts on use and I think it's likely that a script conflict is causing your trouble.

    Posted 6 years ago on Friday August 10, 2012 | Permalink
  3. Hi, I believe I am suffering a similar JQuery version issue. I cannot create a form in the admin. I get see the GUI but when I try to work with it by add a field? I get a AJAX error.

    I am running GF with WP theme Purity. I performed the GF suggestion of first switching the site theme to twenty-ten. When I did, I could use the GF form builder.

    I checked the Purity Theme site forum on themeforest.net and found a post with similar issue. Theme author recommended to REMOVE (from function.php) the following lines (put on pastebin)

    http://pastebin.com/ebJntRpQ

    original post: http://themeforest.net/item/purity-clean-minimal-bold-wordpress-theme/discussion/639774?page=2

    After I followed the instructions? The issue remains.

    Any help would be appreciated

    Posted 6 years ago on Tuesday August 14, 2012 | Permalink
  4. Perhaps you could try turning on the No Conflict mode in the Gravity Forms settings page to see if that makes a difference or helps resolve their conflict.

    Posted 6 years ago on Tuesday August 14, 2012 | Permalink
  5. Hi Rob,
    I should have mentioned that in org post. Is already turned on.

    Posted 6 years ago on Tuesday August 14, 2012 | Permalink
  6. Sometimes those AJAX errors can be related to low PHP Memory. You could try increasing that by following the instructions here:

    http://www.nerdgrind.com/increase-wordpress-and-php-memory-limit/

    Posted 6 years ago on Tuesday August 14, 2012 | Permalink
  7. @eirlymeyer - I was able to install this form on my server and submit it fine. An entry was recorded. You should have received an email confirmation of my submission. At this point, it looks like either a plugin or theme conflict. You need to start debugging this by following these instructions to test for theme or plugin conflicts http://rkt.gs/testing

    Thank you.

    Posted 6 years ago on Friday August 17, 2012 | Permalink