PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form Issues in IE7 & 8

  1. aaronu
    Member

    Hi There,

    Hoping to get some help on a site I'm developing. The forms appear as expected on most modern browsers, but in IE7 and IE8 the forms look like they are squished to the left side of the page.

    IE8 Screenshot: http://www.evernote.com/pub/aaronu/shared#b=c1a9fec3-8472-4017-b80c-53bdcceaee0a&n=1a1db565-a5ea-4f5c-844c-04bacb09cfbe

    I don't have any special CSS for Gravity Forms enabled, and the alignment is currently set to top. Any ideas what I might need to do to get it to display the full width again?

    Thanks!

    Posted 8 years ago on Wednesday June 8, 2011 | Permalink
  2. Can you post a URL to your form page so we can check it out? It's difficult to debug just from a screenshot.

    Posted 8 years ago on Wednesday June 8, 2011 | Permalink
  3. aaronu
    Member

    Sure. This is a dev site, so apologies for the process.

    Temp access: http://markmaimon.com?wpjf3_mr_temp_access_key=tm4JwtQmAxnQOZd6L8RN

    The forms on these two pages have the same problem in IE7 and IE8. No other forms seem to be affected:

    http://markmaimon.com/apply-now/
    http://markmaimon.com/service-evaluation/

    Thanks!

    Posted 8 years ago on Wednesday June 8, 2011 | Permalink
  4. I don't have a machine to test IE right at the moment so will do that asap, but for now I'm seeing a few things in your markup. It appears that your content area may not be defined properly because of a spelling error.

    You have

    <div id="ontent-fullwidth">

    and your class name that defines the width is actually "content-fullwidth" so that may be part of the issue. The form wrapper is set to be at a max percentage width of the available area. IE may not be rendering that the same as the others.

    Also, I don't see any width defined on the ".maincontent" div. That may also be why IE is rendering it strangely. You may need to define a width for that. Again, not 100% sure but I know that IE is weird about undefined widths, etc.

    You could always try setting a width on the form wrapper itself.

    [css]
    body .gform_wrapper {width:600px}

    I'm assuming that you've checked your forms in the preview window and they look right there?

    Posted 8 years ago on Wednesday June 8, 2011 | Permalink
  5. aaronu
    Member

    Thanks, Kevin! You fixed it. Turns out that I needed to set the ".maincontent" div width. I wouldn't have figured that one out without your help. I appreciate the quick reply!

    Posted 8 years ago on Friday June 10, 2011 | Permalink
  6. Wonderful. Thanks for the update. I'm happy I could help out.

    Posted 8 years ago on Friday June 10, 2011 | Permalink

This topic has been resolved and has been closed to new replies.