PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form layout different in IE

  1. icon12345
    Member

    Hi I am new to GF, but have read as much as i can on the product using CSS layouts etc.

    After adding my first test form I am getting a discrepancy between what Chrome, Firefox, Safari and Camino is displaying and how IE is displaying the page (with the later being incorrect).

    I have only edited the css file (after appending to my own style.css) to change the left margin - but even using the default css file get the same issue.
    Is it coding in my own page causing a conflict?
    Any help is appreciated.
    Here is an example page, try viewing in any of the above and then IE.

    'http://www.iconhealthconnections.com.au/?page_id=64'

    Kind Regards
    Dan

    Posted 12 years ago on Tuesday April 20, 2010 | Permalink
  2. Hey Dan,

    Gravity Forms works fine with IE out of the box. There must be something with your theme styles that's causing your problem.

    I copied your page and CSS file, copied it to my test area, replaced the Gravity Forms section with a fresh copy of the default forms.css styles and it worked fine.

    IE 7 Screenshot

    I did notice that your style.css file is jacked up a bit because the first commented section isn't closed properly. This could be related and may be causing some additional problems for you.

    Screenshot

    Hope that helps out.

    Posted 12 years ago on Tuesday April 20, 2010 | Permalink
  3. icon12345
    Member

    Great spot on the CSS, this (and other corrections found!) cured the issue.
    Thanks

    Posted 12 years ago on Thursday April 22, 2010 | Permalink
  4. I'm pleased I could help. Thanks for the update.

    Posted 12 years ago on Thursday April 22, 2010 | Permalink
  5. I'm having the same problem with Internet Explorer. My zipcode field is not aligned, but looks just fine in chrome or firefox. Help?

    http://www.myindependentcaregiver.com/

    And, any advice on how to style my input fields? How to make them pretty when my background is white. Any advice would be appreciated.

    Posted 9 years ago on Friday November 9, 2012 | Permalink