PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form not appearing

  1. Just updated to the most recent version of the plugin and our form is no longer appearing. I've tried trashing the page with the shortcode and recreating it, deactivating and activating the plugin again, redoing the shortcode with the toolbar button. No luck.

    The form shows fine on the preview within the plugin, but not on the live page itself.

    Help? Any advice? We're (supposed to be) using this form actively for class registrations today.

    Thanks,
    Dave

    Posted 7 years ago on Tuesday May 22, 2012 | Permalink
  2. How do we go back to the prior version of the plugin?

    Posted 7 years ago on Wednesday May 23, 2012 | Permalink
  3. I assume you have conditional logic on your form? Do you have a link to share?

    Run through the instructions here on checking for a theme/plugin conflict:
    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 7 years ago on Wednesday May 23, 2012 | Permalink
  4. Yes, conditional logic. Sorry, I put the link on the original submission form...not sure why it did not show:

    http://www.ngcdale.com/register

    I tried the Twenty Ten theme just now and the form now works. So, it's some conflict with the theme. However, it's not a practical option to go away from this theme since we have so much content built around it (we do have the latest version installed).

    If there's nothing easy that can be changed, how do I roll back to a prior version of your plugin?

    Posted 7 years ago on Wednesday May 23, 2012 | Permalink
  5. I noticed that your theme is running an old version of jQuery: Screenshot Updating this to be the latest version could potentially solve your woes, we are up to version 1.7.1.

    Otherwise, there would be a JS conflict somewhere, so you could comment out scripts one-by-one to see if you can find the culprit in the theme. Try this out and let me know how it goes. It's ideal that you can keep up-to-date with Gravity Forms and WordPress, as we do develop the code very tightly and always include new features and patches, as when WordPress does the same. We will help pinpoint this issue with you. Let me know what you find out.

    Posted 7 years ago on Wednesday May 23, 2012 | Permalink
  6. pixellunch
    Member

    I am having the same issue with my theme. I activated Twenty Eleven and the conditional logic worked fine. But I am using Hybrid 1.1 by RocketTheme and when my theme is activated the form quits appearing.

    I really need conditional logic for this form and I'm also too invested in my theme to change themes. Can someone help?

    Website:
    http://snkc.net

    Form preview (without conditional logic. If I had conditional logic, it would be blank)
    http://snkc.net/_spaneukancit/?gf_page=preview&id=1

    It appears that I am already using jquery version 1.7.1

    Thank you.

    Posted 7 years ago on Friday May 25, 2012 | Permalink
  7. Can you embed the form that has conditional logic not working onto a private page - you can duplicate the form if you need to and provide the specific URL to the form with conditional logic that doesn't show.

    Posted 7 years ago on Friday May 25, 2012 | Permalink
  8. pixellunch
    Member

    Ummm, it's working now. WTF?!?!?! I just troubleshooted it for an hour. I closed it out, logged completely out of Wordpress, and only went back in to duplicate it when I saw your response and now it's working. Magic?

    http://snkc.net/services/online-surgery-appointment-form/

    Select "2" on the question that asks "How many pets do you need to make surgery appointments for?*" and info for Pet #2 appears below. I am not sure why it's working now, but I suppose I should run with it. Thanks!

    Posted 7 years ago on Friday May 25, 2012 | Permalink
  9. Right on, could have been related to a renamed field or even a deleted field that still had conditional logic applied to it. Usually when this is the case, duplicating the form will clear that up if it's lingering.

    Posted 7 years ago on Friday May 25, 2012 | Permalink
  10. Hi

    Just for your information, I get a blank page with conditional logic and I have turned off all the plugins 1 by 1 until I found that the problem with my conditional logic not working is the 'Shareaholic | email, bookmark, share buttons' plugin, perhaps you could look into this?

    Thank you
    Nic

    Posted 7 years ago on Thursday August 16, 2012 | Permalink
  11. Please post a link to your form when Shareaholic is active. We can tell you what the error is but won't be able to fix it for you. If the error is coming from the Shareaholic plugin, you will need to contact the plugin author to resolve that issue.

    Posted 7 years ago on Thursday August 16, 2012 | Permalink
  12. My form is not appearing either. I have disabled every plugin and tried the form in the Twenty Ten theme. Nothing. The form will not even appear when I choose preview. Please Help.

    Posted 7 years ago on Tuesday October 9, 2012 | Permalink
  13. Ok, I have narrowed this down to the conditional logic. When I disable all of the conditional logic the for appears. I have made sure that I have the latest WordPress Upgrade already. Can you please tell me what the javascript/jquery conflict might be? I'm on a time crunch and this hurting us a bit.
    http://www.midamericatoxicology.com/registration/

    thanks

    Posted 7 years ago on Tuesday October 9, 2012 | Permalink
  14. When you have a form with conditional logic which fails to show, it's typically due to a JavaScript or jQuery error. You have a JavaScript error on that page:

    Timestamp: 10/10/2012 9:25:06 AM
    Error: ReferenceError: gf_right_half is not defined
    Source File: http://www.midamericatoxicology.com/registration/
    Line: 187

    It looks to me like you pasted a CSS Ready Class (gf_right_half) into the area for the max character count for one of the fields. Please check for that.

    Posted 7 years ago on Wednesday October 10, 2012 | Permalink
  15. Thanks for the response. I realize, for other forum topics, that it is usually because of JavaScript or JQuery errors. That doesn't help me much. I have not pasted a CSS Ready Class. Can you narrow this down for me? We just bought this plugin and if we can't get the conditional logic to work we will have to count it as a lost and use Quform (which I would rather not do).

    Posted 7 years ago on Thursday October 11, 2012 | Permalink
  16. Can you send over a WP Admin login to rob@rocketgenius.com and reference this post in your email so I can take a look?

    Posted 7 years ago on Thursday October 11, 2012 | Permalink
  17. Resolved via email.

    Posted 7 years ago on Thursday October 11, 2012 | Permalink

This topic has been resolved and has been closed to new replies.