PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form not collecting logged in user data

  1. Hi guys,

    I'm having a problem where a form I have deployed on a membership site is not collecting logged-in user data. I know that each entry is being completed by a logged in user because I have the form set to only display if the user is logged in, and the form is also on a protected page that can't even be accessed unless the user is logged in.

    Any idea what's going on here? It worked when I tested it and for the first few entries, then stopped.

    As an aside, is there any way to recover this info if I know the user was logged in? As it is, I have some fairly important entries submitted now, and I have no idea who they belong to...

    Posted 8 years ago on Monday January 16, 2012 | Permalink
  2. Okay, it looks like the form actually is registering the username, so I'm not totally lost on the existing entries anymore, but the problem still exists that the fields are not collecting the default values that I'm pretty sure *must* be available since the user has to be logged in to see the form.

    Posted 8 years ago on Monday January 16, 2012 | Permalink
  3. dochara
    Member

    This sounds like the bug with auto population which has arisen since the latest WP update. It is apparantly fixed in the next GF release, in the meantime there is a fix here:
    http://www.gravityhelp.com/forums/topic/auto-population-stopped-working-in-331

    Posted 8 years ago on Tuesday January 17, 2012 | Permalink
  4. Cheers!

    I haven't tried the fix yet, but I did find where David was offering an update to affected users and sent an email:

    http://www.gravityhelp.com/forums/topic/wp-33-and-gf-form-problem#post-44753

    Posted 8 years ago on Tuesday January 17, 2012 | Permalink